Buy and Resell HDU - 6438(贪心+优先队列)

Buy and Resell HDU - 6438

The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i-th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i-th city and choose exactly one of the following three options on the i-th day:

  1. spend ai dollars to buy a Power Cube
  2. resell a Power Cube and get ai dollars if he has at least one Power Cube
  3. do nothing

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n
cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.
Input
There are multiple test cases. The first line of input contains a positive integer T (T≤250), indicating the number of test cases. For each test case:
The first line has an integer n. (1≤n≤105)
The second line has n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i-th city. (1≤ai≤109)
It is guaranteed that the sum of all n is no more than 5×105
.
Output
For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.
Sample Input

3
4
1 2 10 9
5
9 5 9 10 5
2
2 1

Sample Output

16 4
5 2
0 0

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. 

  profit = - 1 - 2 + 10 + 9 = 16
In the second case, he will buy in 2 and resell in 4. 

  profit = - 5 + 10 = 5
In the third case, he will do nothing and earn nothing. 

  profit = 0

这道题和Buy Low Sell High CodeForces - 867E是一模一样的,只不过这道题多了一问,求最小交易次数,可以先看一下链接的题目,只求最大利润,对于计数交易次数,我们只需要记录是个值在队列中有没有中间值,如果要pop的时候,存在中间值(队列中有两个)那么次数不加,如果有一个,那么次数加二,一买一卖

code:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
priority_queue<int,vector<int>,greater<int> >q;
map<int,int> st;
int main(){
    int n,w;
    ll ans = 0;
    int t;
    scanf("%d",&t);
    while(t--){
        st.clear();
        while(!q.empty()) q.pop();
        ll num = 0;
        ans = 0;
        scanf("%d",&n);
        while(n--){
            scanf("%d",&w);
            if(!q.empty() && w > q.top()){
                if(st[q.top()] > 0) st[q.top()]--;
                else num += 2;
                st[w]++;
                ans += w - q.top();
                q.pop();
                q.push(w);
            }
            q.push(w);
        }
        printf("%lld %lld\n",ans,num);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/codeswarrior/article/details/82111153