pat-1046 Shortest Distance(20)(简单题)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

思路很简单,就是正着走路短,还是逆着走路短,要注意一下先把sum存起来省点时间就行。 

#include<cstdio>
#include <cstring>
#include<algorithm>
#include <iostream>
#include <cmath>
using namespace std;
const int maxn = 1e5 + 5;
int a[maxn],c[maxn];
int main()
{
  
    int n,m,x,y,sum ,total = 0,res;
    scanf("%d",&n);
    if(n < 3)
        return 0;
    for(int i = 1 ; i <= n ; i ++)
    {
       
        scanf("%d",&a[i]);
        total += a[i];
        c[i] = total;//牺牲空间 减少时间,先存起来
    }
  
    scanf("%d",&m);
    for(int i = 0 ; i < m;i++)
    {
        sum = 0;
        res = 0;
        scanf("%d%d",&x,&y);
        if(x > y)
            swap(x,y);
//        for(int j = x ; j < y;j++)//每次都加一遍最后一个测试点超时
//            sum += a[j];
        sum = c[y - 1] - c[x - 1];
        res = min(sum , total - sum);
        cout<<res<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hzyhfxt/article/details/82182026