pat-1037 Magic Coupon(25)(排序简单题)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​ product values. Here 1≤N​C​​,N​P​​≤10​5​​, and it is guaranteed that all the numbers will not exceed 2​30​​.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

用了最土的办法,没用任何技巧,写了快100行,一次过,这种感觉~很美妙~

【五分钟后更新】原来大家只要写二十几行....

#include<cstdio>
#include <cstring>
#include<algorithm>
#include <iostream>
#include <cmath>
using namespace std;
const int maxn = 1e5 + 5;
int goods[maxn],coupon[maxn],coupon_f[maxn],coupon_z[maxn],goods_f[maxn],goods_z[maxn];
bool cmp(int a,int b)
{
    return a > b;
}
int main()
{
    int a,b,c,sum = 0;
    int f1 = 1 ,f2 = 1;
    int tmp1 = 0,tmp2 = 0,tmp11 = 0,tmp22 = 0;
    cin>>a;
    for(int i = 0 ; i < a; i++)
    {
        cin>>coupon[i];
        if(coupon[i] < 0)
            f1 = 1;
    }
    cin>>b;
    for(int i = 0 ; i < b ;i ++)
    {
        cin>>goods[i];
        if(goods[i] < 0)
            f2 = 1;
    }
    if(f1 == 0 && f2 == 0)//都是正的
    {
        sort(coupon,coupon + a,cmp);
        sort(goods,goods + b,cmp);
        c = max(a,b);
        for(int i = 0 ; i < c ;i++)
        {
            sum += coupon[i] * goods[i];
        }
    }
    else if(f1 == 1 && f2 == 0)//券里有负的,商品都是正的
    {
        sort(coupon,coupon + a,cmp);
        sort(goods,goods + b,cmp);
        c = max(a,b);
        for(int i = 0 ; i < c;i++)
        {
            if(coupon[i] < 0)
                break;
            sum += coupon[i] * goods[i];
        }
    }
    else if(f1 == 0 && f2 == 1)//券都是正的,商品里有负的
    {
        sort(coupon,coupon + a,cmp);
        sort(goods,goods + b,cmp);
        c = max(a,b);
        for(int i = 0 ; i < c;i++)
        {
            if(goods[i] < 0)
                break;
            sum += coupon[i] * goods[i];
        }
    }
    else if(f1 == 1 && f2 == 1)
    {
        for(int i = 0 ; i < a; i++)
        {
            if(coupon[i] < 0)
                coupon_f[tmp1 ++] = coupon[i];
            if(coupon[i] > 0)
                coupon_z[tmp2 ++] = coupon[i];
        }
        sort(coupon_f,coupon_f + tmp1);//负的小到大排,绝对值大到小
        sort(coupon_z,coupon_z + tmp2,cmp);//正的大到小排
        for(int i = 0 ; i < b; i++)
        {
            if(goods[i] < 0)
                goods_f[tmp11 ++] = goods[i];
            if(goods[i] > 0)
                goods_z[tmp22 ++] = goods[i];
        }
        sort(goods_f,goods_f + tmp11);//负的小到大排,绝对值大到小
        sort(goods_z,goods_z + tmp22,cmp);//正的大到小排
        int d = max(tmp2,tmp22);
        for(int i = 0;i < d;i++)//正的部分大到小分别相乘加起来就行
        {
            sum += goods_z[i] * coupon_z[i];
        }
        int f = max(tmp1,tmp11);
        for(int i = 0;i < f;i++)//负的部分小到大分别相乘 再加起来
        {
            sum += goods_f[i] * coupon_f[i];
        }
    }
    cout<<sum<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hzyhfxt/article/details/82150051
今日推荐