PAT甲级--1116 Come on! Let's C(20 分)【模拟题+简单逻辑】

1116 Come on! Let's C(20 分)

"Let's C" is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

  • 0、 The Champion will receive a "Mystery Award" (such as a BIG collection of students' research papers...).
  • 1、 Those who ranked as a prime number will receive the best award -- the Minions (小黄人)!
  • 2、 Everyone else will receive chocolates.

Given the final ranklist and a sequence of contestant ID's, you are supposed to tell the corresponding awards.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​4​​), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant's ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID's.

Output Specification:

For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding? instead. If the ID has been checked before, print ID: Checked.

Sample Input:

6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

Sample Output:

8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

解题思路:这题大家一看立马理解题意,但是怎么处理排名呢,怎么处理重复的呢,我这里是用了map,最近爱上了map,map有2个量,前面存储他们的ID,后面存储他们的排名,接下来就分几种情况,第一种是存在的,就是大于0,然后再判断排名是不是素数然后输出相应的奖品,然后将其排名赋值为-1;第二种不存在的就是等于0,直接输出结果,还有是存在但是之前就是访问过的,就是-1也就是小于0,直接输出结果,然后这题就ok了。

#include<bits/stdc++.h>
using namespace std;
bool is_prime(int n)
{
	if(n<=1) return false;
	for(int i=2;i<=sqrt(n);i++)
	{
		if(n%i==0) return false;
	}
	return true;
}
int main(void)
{
	int n;
	scanf("%d",&n);
	map<string,int>mapp;
	for(int i=1;i<=n;i++)
	{
		string s;
		cin>>s;
		mapp[s]=i;
	}
	int m;
	scanf("%d",&m);
	for(int i=0;i<m;i++)
	{
		string s;
		cin>>s;
		if(mapp[s]>0)
		{
			if(mapp[s]==1)
			{
		    	 cout<<s<<": Mystery Award"<<endl; 
		    	  mapp[s]=-1;
		    }
			else if(is_prime(mapp[s]))
			{
			   cout<<s<<": Minion"<<endl;
			   mapp[s]=-1;
	    	}
	    	else
			{
				cout<<s<<": Chocolate"<<endl;
				mapp[s]=-1;
			 } 
		}
		else if(mapp[s]<0) cout<<s<<": Checked"<<endl;
		else cout<<s<<": Are you kidding?"<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/82252360