暑假集训day9——迷失の搜索树

迷失の搜索树

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

小璐在机缘巧合之下获得了一个二叉搜索树,这个二叉搜索树恰好有n个节点,每个节点有一个权值,每个节点的权值都在[1,n]这个区间内,并且两两不相同,真是优美的性质啊

但是命运的不公又让她失去了这个二叉搜索树

幸运的是,她还记得自己丢失的二叉搜索树的前序遍历序列。

在丢了二叉搜索树之后,小璐无比想念她的这个树的后序遍历

那么问题来了,聪明的你在知道这个二叉搜索树的前序遍历的序列的情况下,能帮她找到这个二叉搜索树的后序遍历嘛?

Input

 多组输入,以文件结尾

每组数据第一行为一个整数n,代表这个二叉搜索树的节点个数(1<=n<=100)

接下来一行n个整数,代表这个二叉搜索树的前序遍历序列

Output

输出n个整数

表示这个二叉树的后序遍历序列

Sample Input

5
4 2 1 3 5

Sample Output

1 3 2 5 4

Hint

 二叉查找树是一棵空树,或者是具有下列性质的二叉树:

若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值

若它的右子树不空,则右子树上所有结点的值均大于它的根结点的值

它的左、右子树也分别为二叉排序树

Source

2016暑假集训结训赛 by QAQ

#include<stdio.h>
#include<string.h>
#include<stdlib.h>

struct node
{
    int data;
    struct node *l, *r;
};

char s[100], s1[100];
int len, len1, k;

struct node *creat(struct node *root, int x)
{
    if(!root)
    {
        root = (struct node*)malloc(sizeof(struct node));
        root-> data = x;

        root-> l = NULL;
        root-> r = NULL;
    }

    else
    {
        if(root-> data > x)
        {
            root-> l = creat(root-> l, x);
        }

        else
        {
            root-> r = creat(root-> r, x);
        }
    }

    return root;
}

void hou(struct node *root)
{

    if(root)
    {
        hou(root-> l);
        hou(root-> r);
        if(!k)
        {
            printf("%d", root-> data);
            k++;
        }

        else
        {
            printf(" %d", root-> data);
        }
    }
}

int main(void)
{
    int x, n, i;
    struct node *root;

    while(~scanf("%d", &n))
    {
        root = NULL;
        k = 0;
        for(i = 0; i < n; i++)
        {
            scanf("%d", &x);
            root = creat(root, x);
        }
        hou(root);
        printf("\n");
    }

    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/Eider1998/article/details/81532107