PAT:A1023 Have Fun with Numbers

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Ecloss/article/details/82183535

PAT:A1023 Have Fun with Numbers

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

struct bign{
	int d[30];
	int len;
	bign() {
		len = 0;
		memset(d, 0, sizeof(d));
	}
};

//	2. change
bign change(char a[]) {
	bign c;
	c.len = strlen(a);
	for(int i = 0; i < c.len; i++) {
		c.d[i] = a[c.len - 1 - i] - '0';
	}
	return c;
}

//	3. compare
int compare(bign a, bign b) {
	if(a.len > b.len) return 1;
	else if(a.len < b.len) return -1;
	else {
		for(int i = 0; i < a.len; i++) {
			if(a.d[i] > b.d[i]) return 1;
			else if(a.d[i] < b.d[i]) return -1;
		}
		return 0;
	}
}

// 4. print
void print(bign a) {
	for(int i = a.len - 1; i >= 0; i--) {
		printf("%d", a.d[i]);
	}
}

// 5. 高精度整数 与 低精度整数的乘法
bign mult(bign a, int b) {
	bign c;
	int carry = 0;
	for(int i = 0; i < a.len; i++) {
		int temp = a.d[i] * b + carry;
		c.d[c.len++] = temp % 10;
		carry = temp / 10;
	}
	while(carry != 0) {
		c.d[c.len++] = carry % 10;
		carry = carry / 10;
	}
	return c;
}

// 6.cmp
bool cmp(int a, int b) {
	return a < b;
}

int main() {
	char A[30];
	scanf("%s", A);
	bign a = change(A);
	bign c = mult(a, 2);
	bign d = c;
	sort(a.d, a.d+a.len);
	sort(c.d, c.d+c.len);
	int x = compare(a, c);
	if(x == 0) printf("Yes\n");
	else printf("No\n");
	print(d);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Ecloss/article/details/82183535