LA 3026 Period KMP算法求循环节

题目链接

https://vjudge.net/problem/UVALive-3026

题目

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and
126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 ≤ i ≤ N)
we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be
written as AK, that is A concatenated K times, for some string A. Of course, we also want to know
the period K.
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains
N (2 ≤ N ≤ 1000000) the size of the string S. The second line contains the string S. The input file
ends with a line, having the number zero on it.
Output
For each test case, output ‘Test case #’ and the consecutive test case number on a single line; then, for
each prefix with length i that has a period K > 1, output the prefix size i and the period K separated
by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4

题意

给定一个长度为n的字符串S,求它每个前缀的最短循环节。换句话说,对于每个i,求一个最大的整数K,使得S的前i个字符组成的前缀是某个字符重复K(K>1)次得到。输出所有存在K的i和对应的K。

解题

设pre[i]表示S[i…len]的最长后缀S[i…i+pre[i]-1]与前缀[1…pre[i]]恰好相等。
上面的pre数组我叫它前缀数值,也有说法叫next数值。都差不多。
求pre的过程显然可以通过递推去解决。
j=pre[i-1].
pre[i]=j+1,当S[i]==S[j+1].
否则不停的j=pre[j],找到使得S[j+1]==S[i]的那个j或者j=0.

长度为N的字符串的最小循环节就是:N - pre[N]。

AC代码

#include <bits/stdc++.h>
using namespace std;

const int maxn=1e6+7;
int pre[maxn],len;
char str[maxn];

void getPre()
{
    memset(pre,0,sizeof(pre));
    int j=0;
    for(int i=2;i<=len;i++)
    {
        while(j>0 && str[j+1]!=str[i]) j=pre[j];
        if(str[j+1]==str[i]) j++;
        pre[i]=j;
    }
}
int main()
{
    int kase=0;
    while(~scanf("%d",&len),len)
    {
        scanf("%s",str+1);
        getPre();
        printf("Test case #%d\n",++kase);
        //for(int i=1;i<=len;i++)
           // printf("%d %d\n",i,pre[i]);
        for(int i=2;i<=len;i++)
        {
           // int loop=i-pre[i];
            if(i%(i-pre[i])==0 && pre[i]) printf("%d %d\n",i,i/(i-pre[i]));
        }
        putchar(10);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37685156/article/details/81484752