【数位DP】H - F(x) HDU - 4734

F(x)

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8478    Accepted Submission(s): 3339


 

Problem Description

For a decimal number x with n digits (AnAn-1An-2 ... A2A1), we define its weight as F(x) = An * 2n-1 + An-1 * 2n-2 + ... + A2 * 2 + A1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).

 

Input

The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 109)

 

Output

For every case,you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output the answer.

 

Sample Input

 

3

0 100

1 10

5 100

 

Sample Output

 

Case #1: 1 Case #2: 2 Case #3: 13

 

Source

2013 ACM/ICPC Asia Regional Chengdu Online

#include <bits/stdc++.h>
using namespace std;

int a[15], b[15];
int dp[15][25000];

int dfs(int pos, int sum, bool lim)
{
	if (pos == 0)
		return 1;
	if (!lim && dp[pos][sum])
		return dp[pos][sum];

	int res = 0;
	int up = lim ? b[pos] : 9;
	for (int i = 0; i <= up; i++)
	{
		int t = sum - i * (1 << (pos - 1));
		if (t < 0)
			break;
		res += dfs(pos - 1, t, lim && (i == up));
	}
	if (!lim)
		dp[pos][sum] = res;
	return res;
}

int solve(int x, int y)
{
//	memset(dp, 0, sizeof dp);
/// 500ms  T 1w 不能每次清空

	int LIMIT = 0;
	int w1 = 0, w2 = 0;
	while (x > 0)
	{
		a[++w1] = x % 10;
		x /= 10;
	}
	for (int i = 1; i <= w1; i++)
		LIMIT += a[i] * (1 << (i - 1));

	while (y > 0)
	{
		b[++w2] = y % 10;
		y /= 10;
	}
	return dfs(w2, LIMIT, 1);
	/// 低位允许的总和
}

int main()
{
	int t;
	scanf("%d", &t);
	for (int i = 1; i <= t; i++)
	{
		int a, b;
		scanf("%d %d", &a, &b);
		printf("Case #%d: %d\n", i, solve(a, b));
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ummmmm/article/details/81744344