HDU 1757 A Simple Math Problem【矩阵快速幂】

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_37867156/article/details/81585493

Lele now is thinking about a simple function f(x). 
If x < 10 f(x) = x. 
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10); 
And ai(0<=i<=9) can only be 0 or 1 . 
Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m. 

Input

The problem contains mutiple test cases.Please process to the end of file. 
In each case, there will be two lines. 
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9. 

Output

For each case, output f(k) % m in one line.

Sample Input

10 9999
1 1 1 1 1 1 1 1 1 1
20 500
1 0 1 0 1 0 1 0 1 0

Sample Output

45
104

题解:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <set>
#include <map>
#define INF 0x3f3f3f3f
#define LL long long
using namespace std;
const int maxn=1005;
int k,m;
struct Matrix{
	int mat[10][10];
}ans,res; 
Matrix Mul(Matrix a,Matrix b){//矩阵乘法
	Matrix tmp;
	for(int i=0;i<10;i++){
		for(int j=0;j<10;j++)
			tmp.mat[i][j]=0;
	}
	for(int i=0;i<10;i++){
		for(int j=0;j<10;j++){
			for(int h=0;h<10;h++){
				tmp.mat[i][j]=(tmp.mat[i][j]+a.mat[i][h]*b.mat[h][j])%m;
			}
		}
	}
	return tmp;
}
void quick_pow(int n){//快速幂
	for(int i=0;i<10;i++){
		for(int j=0;j<10;j++){
			if(i==j) ans.mat[i][j]=1;
			else ans.mat[i][j]=0;
		}
	}
	while(n){
		if(n&1)
			ans=Mul(ans,res);
		res=Mul(res,res);
		n>>=1;
	}
}
int main(){
	while(~scanf("%d%d",&k,&m)){
		if(k<10){
			printf("%d\n",k);
			continue;
		}
		memset(res.mat,0,sizeof res.mat);
		for(int i=0;i<10;i++)
			scanf("%d",&res.mat[0][i]);
		for(int i=1;i<10;i++)
			res.mat[i][i-1]=1;
		quick_pow(k-9);
		int sum=0;
		for(int i=0;i<10;i++)
			sum+=ans.mat[0][i]*(9-i);
		printf("%d\n",sum%m);
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37867156/article/details/81585493