HDU 3746 【kmp入门应用】

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task. 

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2: 


Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden. 
CC is satisfied with his ideas and ask you for help.

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases. 
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input

3
aaa
abca
abcde

Sample Output

0
2
5

题意:

给你一串字符,问你它是不是循环的,不是就输出这个字符串需要多长才能构成一个循环。。。

想法及应用:

当时看到这题,一想可以遍历一遍next数组,把next[ i ]==0的用ans++,如果ans==长度 -1;就输出原本长度,如果不是,就输出ans,然后过了样例,信心满满,一交就wa了,然后问度娘,看博客,才发现这是kmp的应用——(最小)循环节,

即————在next数组中,若 长度 len%( len - next[ len ] )==0&& next != 0,则字符串循环,且循环节长度为:len - next [ len ]。。

所以改良之后就过了。。。。。。

ac代码:

#include<cstdio>
#include<cstring>
const int MAXN=1e5+2;
int next[MAXN];
char s[MAXN];
int m;
void get_next() {
    int i=1;
    int j=0;
    next[0]=0;
    while(i<m) {
        if(s[i]==s[j]) {
            next[i]=++j;
            i++;
        } else if(!j) {
            i++;
        } else {
            j=next[j-1];
        }
    }

}
int main() {
    int t;
    scanf("%d",&t);
    while(t--) {
        memset(next,0,sizeof(next));
        scanf("%s",s);
        m=strlen(s);
        get_next();
        int ans=m-next[m-1];
        if(ans==m)
            printf("%d\n",m);
        else if(m%ans==0&&next[m-1]!=0)
            printf("0\n");
        else
            printf("%d\n",ans-m%ans);
    }
    return 0;
}

优美的文字——代码!!!

猜你喜欢

转载自blog.csdn.net/sf_yang35/article/details/81813167
今日推荐