ACM-ICPC 2018 南京赛区网络预赛----The writing on the wall

题目链接

Feeling hungry, a cute hamster decides to order some take-away food (like fried chicken for only 3030 Yuan).

However, his owner CXY thinks that take-away food is unhealthy and expensive. So she demands her hamster to fulfill a mission before ordering the take-away food. Then she brings the hamster to a wall.

The wall is covered by square ceramic tiles, which can be regarded as a n * mn∗m grid. CXY wants her hamster to calculate the number of rectangles composed of these tiles.

For example, the following 3 * 33∗3 wall contains 3636 rectangles:

Such problem is quite easy for little hamster to solve, and he quickly manages to get the answer.

Seeing this, the evil girl CXY picks up a brush and paint some tiles into black, claiming that only those rectangles which don't contain any black tiles are valid and the poor hamster should only calculate the number of the valid rectangles. Now the hamster feels the problem is too difficult for him to solve, so he decides to turn to your help. Please help this little hamster solve the problem so that he can enjoy his favorite fried chicken.

Input

There are multiple test cases in the input data.

The first line contains a integer TT : number of test cases. T \le 5T≤5.

For each test case, the first line contains 33 integers n , m , kn,m,k , denoting that the wall is a n \times mn×m grid, and the number of the black tiles is kk.

For the next kk lines, each line contains 22 integers: x\ yx y ,denoting a black tile is on the xx-th row and yy-th column. It's guaranteed that all the positions of the black tiles are distinct.

For all the test cases,

1 \le n \le 10^5,1\le m \le 1001≤n≤105,1≤m≤100,

0 \le k \le 10^5 , 1 \le x \le n, 1 \le y \le m0≤k≤105,1≤x≤n,1≤y≤m.

It's guaranteed that at most 22 test cases satisfy that n \ge 20000n≥20000.

Output

For each test case, print "Case #xx: ansans" (without quotes) in a single line, where xx is the test case number and ansans is the answer for this test case.

Hint

The second test case looks as follows:

样例输入

2
3 3 0
3 3 1
2 2

样例输出

Case #1: 36
Case #2: 20

 n*m矩阵中有多少个全为1的子矩阵。

#include <bits/stdc++.h>
using namespace std;

#define Maxn 100005

int n,m,s[Maxn][110],num[Maxn][110];
int sta[Maxn],top,up[Maxn],down[Maxn];//up当前点向上最大的拓展距离,down当前点向下最大的拓展距离

int main()
{
    int T,k,cas=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d %d",&n,&m,&k);
        for (int i=1;i<=n;++i)
            for (int j=1;j<=m;++j)
                s[i][j]=1;
        for(int i=0;i<k;i++)
        {
            int x,y;
            scanf("%d %d",&x,&y);
            s[x][y]=0;
        }
        for (int i=1;i<=n;++i)
            for (int j=1;j<=m;++j)
                num[i][j] = (s[i][j]) ? num[i][j-1]+1 : 0;
        long long ans=0;
        for (int j=1;j<=m;++j)
        {
            top = 0;
            for (int i=1;i<=n;++i)//单调栈
            {
                if(num[i][j])
                {
                    up[i]=1;
                    while(top && num[i][j] <= num[sta[top]][j])
                        up[i]+=up[sta[top]],--top;
                    sta[++top]=i;
                }
                else
                {
                    top=0,up[i]=0;
                }
            }
            top = 0;
            for (int i=n;i>=1;--i)
            {
                if(num[i][j])
                {
                    down[i]=1;
                    while(top && num[i][j] < num[sta[top]][j])
                        down[i]+=down[sta[top]],--top;
                    sta[++top]=i;
                }
                else 
                {
                    top=0,down[i]=0;
                }
                ans += (long long)up[i]*(long long)down[i]*(long long)num[i][j];
            }
        }
        printf("Case #%d: %lld\n",cas++,ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/jinghui_7/article/details/82351275
今日推荐