hdu 1078【记忆化搜索入门题】FatMouse and Cheese

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food. 

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole. 

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

Input

There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected. 

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

题意  

从(0,0)这个点出发,每次最多走K步,要求走到的格子数大于原来的,求问总那么多步后总和最大是多少。

记忆化搜索,很多路径有重复的,跟DP有些相似。

【思考】

Select Code
 


#include <iostream>
#include <cstdio>
#include <cstring>
#include <ctime>
#include <algorithm>
#include <cmath>
using namespace std;
 
const int  maxn =105;
int a[maxn][maxn],dp[maxn][maxn];
int n,k;
int dx[]={0,0,1,-1};
int dy[]={1,-1,0,0};
 
int dfs(int x, int y){
    int tmp=0;//执行一次dfs就要化为0 ,不是很懂!!!! 
    for (int j=1;j<=k;j++){
      for (int i=0;i<4;i++){
        int xx=x+dx[i]*j; //k步是水平或竖直的
        int yy=y+dy[i]*j;
        if (xx<0 || yy<0 || xx>=n || yy>=n) continue;
        if (a[x][y]>=a[xx][yy]) continue;
        if (dp[xx][yy]) { //如果已经探索过了,就没必要继续深搜了
            tmp=max(tmp,dp[xx][yy]); //取最大值
            continue;
        }
        tmp=max(tmp,dfs(xx,yy)); //取所有方案中的最大值
      }
    }
    return dp[x][y]=a[x][y]+tmp;///不懂递归过程!!!!! ,理解在思考区 
}
 
int main(){
    std::ios::sync_with_stdio(false); //提高cin输入效率
    while (cin >> n >> k){
        if (n==-1 && k == -1) break;
        for (int i=0;i<n;i++){
            for (int j=0;j<n;j++) cin>>a[i][j];
        }
        memset(dp,0,sizeof(dp));
        cout<<dfs(0,0)<<endl; //最优解在出发点上
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42382758/article/details/81565033