ACM-ICPC An Olympian Math Problem(找规律)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/a17865569022/article/details/82313991

Alice, a student of grade 6, is thinking about an Olympian Math problem, but she feels so despair that she cries. And her classmate, Bob, has no idea about the problem. Thus he wants you to help him. The problem is:

We denote k!:

k! = 1 × 2 × ⋯ × (k − 1) × k

We denote S:

S = 1 × 1! + 2 × 2! + ⋯ + (n − 1) × (n − 1)!

Then S module n is

You are given an integer n.
You have to calculate S modulo n.

Input

The first line contains an integer T (T ≤ 1000), denoting the number of test cases. For each test case, there is a line which has an integer n.
It is guaranteed that 2 ≤ n ≤ 10^18 .

Output

For each test case, print an integer S modulo n.

扫描二维码关注公众号,回复: 3186772 查看本文章

Hint

The first test is: S = 1 × 1! = 1, and 1 modulo 2 is 1.

The second test is: S = 1 × 1! + 2 × 2! = 5 , and 5 modulo 3is 2.
样例输入 复制
2
2
3
样例输出 复制
1
2
打表找规律,可以简单列举前20个较小的数发现结果都是n-1。
打表代码:

#include<bits/stdc++.h>
#define LL long long
using namespace std;
LL del(LL a)
{
    LL temp=1;
    for(LL i=1;i<=a;i++)
        temp*=i;
    return temp;
}
int main()
{
    int t;scanf("%d",&t);
    while(t--)
    {
        LL n;scanf("%lld",&n);
        LL sum=0,k;
        for(LL i=1;i<n;i++)
        {
            sum+=i*del(i);
        }
        cout<<sum%n<<endl;
    }
    return 0;
}

AC代码:

#include<bits/stdc++.h>
#define LL long long
using namespace std;
int main()
{
    int t;scanf("%d",&t);
    while(t--)
    {
        LL n;scanf("%lld",&n);
        cout<<n-1<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/a17865569022/article/details/82313991