The Accomodation of Students HDU - 2444

There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other. 

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room. 

Calculate the maximum number of pairs that can be arranged into these double rooms. 

Input

For each data set: 
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs. 

Proceed to the end of file. 
 

Output

If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms. 

Sample Input

4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6

Sample Output

No
3

通过涂色法判断是否是二分图

是二分图的话 可以建无向图 最后除以 2

或者开两个数组 存各自点

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<cmath>

using namespace std;
const int Maxn = 500;
int un, vn;
int g[Maxn][Maxn];
int linker[Maxn];
int color[Maxn];
bool used[Maxn];
bool dfs(int u){
    for(int v = 0; v < vn; v++){
        if(g[u][v] && !used[v]){
            used[v] = true;
            if(linker[v] == -1 || dfs(linker[v])){
                linker[v] = u;
                return true;
            }
        }
    }
    return false;
}
int s(){
    int res = 0;
    memset(linker, -1, sizeof(linker));
    for(int u = 0; u < un; u++){
        memset(used, false, sizeof(used));
        if(dfs(u))res++;
    }
    return res;
}
int main(){
   int n, m;
   while(scanf("%d %d", &n, &m) == 2){
        memset(g, 0, sizeof(g));
        int flag = 1;
        memset(color, 0, sizeof(color));
        for(int i = 0; i <= m - 1; i++){
            int x, y;
            scanf("%d %d", &x, &y);
            g[x - 1][y - 1] = g[y - 1][x - 1] = 1;
            if(color[x] == 0 && color[y] == 0){
                color[x] = -1; color[y] = 1;
            }
            else if(color[x] != 0 && color[y] == 0){
                    color[y] = -color[x];
            }
            else if(color[x] == 0 && color[y] != 0){
                    color[x] = -color[y];
            }
            else if(color[x] != 0 && color[y] != 0){
                if(color[x] == color[y] && color[x] != 0)flag = 0;
            }
        }
        if(!flag){
            printf("No\n");
            continue;
        }
        vn = un = n;
        printf("%d\n", s() / 2);
   }
   return 0;
}
扫描二维码关注公众号,回复: 3190096 查看本文章

猜你喜欢

转载自blog.csdn.net/qq_32193741/article/details/81940047