【Trie字典树(前缀树)】查询前缀出现次数 A - 统计难题 HDU - 1251

统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 57613    Accepted Submission(s): 20135


 

Problem Description

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).

 

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.

 

Output

对于每个提问,给出以该字符串为前缀的单词的数量.

 

Sample Input

 

banana

band

bee

absolute

acm

ba

b

band

abc

 

Sample Output

 

2

3

1

0

#include <bits/stdc++.h>
using namespace std;

const int mn = 1000010; // 可能的节点数

int num; // 编号 全局变量
int trie[mn][26];
int sum[mn];
void add(char s[])
{
	int root = 0;
	for (int i = 0, len = strlen(s); i < len; i++)
	{
		int id = s[i] - 'a';
		if (trie[root][id] == 0)
			trie[root][id] = ++num;
		root = trie[root][id];

		sum[root]++; // 经过的节点 其出现次数++
	}
}
int ask(char s[])
{
	int root = 0;
	for (int i = 0, len = strlen(s); i < len; i++)
	{
		int id = s[i] - 'a';
		if (trie[root][id] == 0) // 不存在s字符串
			return 0;
		root = trie[root][id];
	}
	return sum[root]; // 该前缀出现次数
}

int main()
{
	char s[20];
	while (gets(s))
	{
		if (s[0] == '\0')
			break;
		add(s);
	}
	while (~scanf("%s", s))
		printf("%d\n", ask(s));
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ummmmm/article/details/82503241
今日推荐