PAT 1001 A+B Format(20 分)

1001 A+B Format(20 分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where 10 6 a , b 10 6 The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:

-1000000 9

Sample Output:

-999,991




解析

第一次做英文的OJ,光读题理解题意就花了好长时间 (ノへ ̄、)


这题的要求就是把数字转换成每三位加一个逗号,
Code:

#include<cstdio>
#include<iostream>
#include<string>
using namespace std;
int main()
{
    int num1, num2;
    cin >> num1 >> num2;
    num1 += num2;
    if (num1<1000 && num1>-1000)
        cout << num1;
    else if (num1<1000000 && num1>-1000000)
        printf("%d,%03d", num1 / 1000, abs(num1) % 1000);
    else
        printf("%d,%03d,%03d", num1 / 1000000,num1/1000-num1/1000000*1000, abs(num1) % 1000);

}

猜你喜欢

转载自blog.csdn.net/weixin_41256413/article/details/82563537
今日推荐