2018中国大学生程序设计竞赛 - 网络选拔赛-Find Integer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 6597    Accepted Submission(s): 1999
Special Judge

 

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n,a,you are required to find 2 integers b,c such that an+bn=cn.

Input

one line contains one integer T;(1≤T≤1000000)

next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)

 

Output

print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);

else print two integers -1 -1 instead.

 

Sample Input

1

2 3

Sample Output

4 5

思路:费马大定理:当整数n >2时,关于x, y, z的方程 x^n + y^n = z^n 没有正整数解。然后就是分情况论事情了

#include<bits/stdc++.h>
using namespace std;

typedef long long ll;
int t;
ll a,n;
int main()
{
    scanf("%d", &t);
    while(t--)
    {
        scanf("%lld%lld", &n, &a);
        ll b,c;
        b = c = 0;
        if(n>2){
            printf("-1 -1\n");
        }else {
            if(n==0){
                printf("-1 -1\n");
            }else if(n==1){
                printf("1 %lld\n",a+1);
            }else{
                if(a<3){
                    printf("-1 -1\n");
                }else{
                    if(a&1){//等价于a%2
                        b = (a*a-1)>>1;
                        c = b+1;
                    }else{
                        b = (a*a-4)/4;
                        c = b+2;
                    }
                    printf("%lld %lld\n", b, c);
                }
            }

        }
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/wys5wys/article/details/82148419