POJ 1003 Max Sum

Max Sum

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
 
Sample Output
Case 1:
14 1 4
 
Case 2:
7 1 6
代码如下:
原理:找出最大串的方法:和并法。遍历的同时将前面的加起来,具体看代码(AC)
#include<stdio.h>
#include<string.h>
int main()
{
    int t,num=0;;
    scanf("%d",&t);
    while(t--)
    {
        num++;
        int n,temp=1,a;//temp表示当前最大区间开头所在位置,一开始假定为1
        scanf("%d",&n);
        int start=1,max=-1001,end1,sum=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a);//a就是区间元素了,由于只用一次,所以就不用数组浪费内存了
            sum+=a;
            if(sum>max)//max 表示目前为止最大区间的和,sum大于max,说明区间改变
            {
              max=sum;
              end1=i+1;
              start=temp;
            }
            if(sum<0)//sum小于0,则表示若前面的temp为开头,不会有最大区间,故将sum,temp重置。
            {
                sum=0;//sum=0表示重新开始计算最大区间(下面的也是这个意思)
                temp=i+2;
            }    
        }    
        printf("Case %d:\n%d %d %d\n",num,max,start,end1);
        if(t!=0)
          printf("\n");                       
    }
    return 0;
} 

猜你喜欢

转载自www.cnblogs.com/shenyuling/p/9690368.html
今日推荐