PAT乙级--1052 卖个萌

萌萌哒表情符号通常由“手”、“眼”、“口”三个主要部分组成。简单起见,我们假设一个表情符号是按下列格式输出的:

[左手]([左眼][口][右眼])[右手]

现给出可选用的符号集合,请你按用户的要求输出表情。

输入格式:

输入首先在前三行顺序对应给出手、眼、口的可选符号集。每个符号括在一对方括号 []内。题目保证每个集合都至少有一个符号,并不超过 10 个符号;每个符号包含 1 到 4 个非空字符。

之后一行给出一个正整数 K,为用户请求的个数。随后 K 行,每行给出一个用户的符号选择,顺序为左手、左眼、口、右眼、右手——这里只给出符号在相应集合中的序号(从 1 开始),数字间以空格分隔。

输出格式:

对每个用户请求,在一行中输出生成的表情。若用户选择的序号不存在,则输出 Are you kidding me? @\/@

输入样例:

[╮][╭][o][~\][/~]  [<][>]
 [╯][╰][^][-][=][>][<][@][⊙]
[Д][▽][_][ε][^]  ...
4
1 1 2 2 2
6 8 1 5 5
3 3 4 3 3
2 10 3 9 3

输出样例:

╮(╯▽╰)╭
<(@Д=)/~
o(^ε^)o
Are you kidding me? @\/@

很有意思的一题 QAQ  o(^ε^)o

需要注意的地方

  • 坑1: Are you kidding me? c程序@\/@是直接打不出来的。需要加\才行 "Are you kidding me? @\\/@"

  • 坑2:无效的输出。如lefteye、righteye等等还可能小于1。(考虑要周全啊~)

  • emmmm本蒻菜到不行。难受

emmmm这里放大佬的题解链接,大佬的总结质量很很很高~@OliverLew

最后放上自己AC代码:

#include<stdio.h>
#include<stdlib.h>

int reademo(char bq[][5]);
main(int argc, char const *argv[])
{
    int i,j,count_s,count_y,count_k;
    char shou[10][5]={{0}};
    char yan[10][5]={{0}};
    char kou[10][5]={{0}};
    count_s=reademo(shou);
    count_y=reademo(yan);
    count_k=reademo(kou);
    int num;
    scanf("%d",&num);
    for(i=0;i<num;i++)
    {
        int lefteye,lefthand,mouth,righteye,righthand;
        scanf("%d %d %d %d %d",&lefthand,&lefteye,&mouth,&righteye,&righthand);

        if((lefteye>count_y)||(righteye>count_y)
        ||(lefthand>count_s)||(righthand>count_s)||(mouth>count_k)
        ||(lefteye<1)||(righteye<1)
        ||(lefthand<1)||(righthand<1)||(mouth<1))
        {
            printf("Are you kidding me? @\\/@\n");
            continue;
        }
        else
        {
            printf("%s(%s%s%s)%s\n",shou[lefthand-1],yan[lefteye-1],kou[mouth-1],yan[righteye-1],shou[righthand-1]);
        }
    }

    system("pause");
    return 0;
}
int reademo(char bq[][5])
{
    char temp;
    int flag=0;
    int count=0;
    int i=0;
    while((temp=getchar())!='\n')
    {
        if(temp=='['&&flag==0)
        {
               flag=1;
               i=0;
               continue;
        }
        else if(temp!=']'&&flag==1)
        {
            bq[count][i++]=temp;
        }
        else if(temp==']'&&flag==1)
        {
            bq[count][i]='\0';
            flag=0;
            //printf("%s  ",bq[count]);
            count++;//记录表情数量
        }
    }
    return count;
}

猜你喜欢

转载自blog.csdn.net/OCEANtroye/article/details/81751260
今日推荐