Cube Stacking(POJ 1988 堆方块 并查集)

版权声明:低调地前行,越努力越幸运! https://blog.csdn.net/SSYITwin/article/details/81872313

Cube Stacking(点击转到

Time Limit: 2000MS   Memory Limit: 30000K
Total Submissions: 28145   Accepted: 9879
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

Source

USACO 2004 U S Open

1.题目含义:

   有N(N<=30,000)堆方块,开始每堆都是一个方块。方块编号1 – N. 有两种操作:
     M x y : 表示把方块x所在的堆,拿起来叠放到y所在的堆上。
     C x : 问方块x下面有多少个方块。
操作最多有 P (P<=100,000)次。对每次C操作,输出结果。

2.牵扯到多组合并,多组查询,考虑用并查集。

      2.1 并查集思路或者说模板就是:初始化——查找——合并 的过程,对应不同的题目,在后两个过程中会有相应的一些改变。

     2.2 本题就多了在查找,合并过程中,更新under[i]和sum[i]的过程。(因为题目中,要求输出查询结果,也就是当前值的下面有多少个方块。所以定义了一个under[]数组保存,因为更新under[]数组的过程中,需要知道父节点为根的总结点数,故而定义sum[]数组)

3.

  34合并到12上面的时候,under[3]=sum[1]  sum[1]=sum[1]+sum[3],然后一直重新赋值。

4.一开始超时,超时原因用的cin读入。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define maxn 31000
int par[maxn];
int sum[maxn]; //表示砖块所在树的总结点数 
int under[maxn];//under[i]表示i下面有多少块 
int p;
void init()
{
	
	for(int i=0;i<maxn;i++)
	{
		par[i]=i;
		sum[i]=1;
		under[i]=0;
	}
}
int getRoot(int x)
{
	if(par[x]!=x)
	{
		int t=getRoot(par[x]);
		under[x]=under[x]+under[par[x]];//见图片 
		par[x]=t;
	}

	return par[x];
}
void Merge(int x,int y)
{
	int fx=getRoot(x);
	int fy=getRoot(y);
	if(fx!=fy)
	   under[fy]=sum[fx],sum[fx]=sum[fx]+sum[fy],par[fy]=fx;//见图片 
}
int main()
{
	char c;
	int x;
	int y;
    init();
	scanf("%d",&p);
    for(int i=0;i<p;i++)
	{
		char s[20];
		int a,b;
		scanf("%s",s);
		if( s[0] == 'M')
		{
			scanf("%d%d",&a,&b);
			Merge(b,a);	
		}
		else
		{
			scanf("%d",&a);
			getRoot(a);
			printf("%d\n",under[a]);
		}
	}
	return 0;
}

5.getchar()读走\n

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define maxn 31000
int par[maxn];
int sum[maxn]; //表示砖块所在树的总结点数 
int under[maxn];//under[i]表示i下面有多少块 
int p;
void init()
{
	
	for(int i=0;i<maxn;i++)
	{
		par[i]=i;
		sum[i]=1;
		under[i]=0;
	}
}
int getRoot(int x)
{
	if(par[x]!=x)
	{
		int t=getRoot(par[x]);
		under[x]=under[x]+under[par[x]];//见图片 
		par[x]=t;
	}

	return par[x];
}
void Merge(int x,int y)
{
	int fx=getRoot(x);
	int fy=getRoot(y);
	if(fx!=fy)
	   under[fy]=sum[fx],sum[fx]=sum[fx]+sum[fy],par[fy]=fx;//见图片 
}
int main()
{
	char c;
	int x;
	int y;
    init();
	scanf("%d",&p);
    for(int i=0;i<p;i++)
	{
		char s;
		int a,b;
		getchar();
		scanf("%c",&s); 
		if( s == 'M')
		{
			scanf("%d%d",&a,&b);
			Merge(b,a);	
		}
		else
		{
			scanf("%d",&a);
			getRoot(a);
			printf("%d\n",under[a]);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SSYITwin/article/details/81872313