FatMouse and Cheese (记忆化搜索)

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food. 

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole. 

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

Input

There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected. 

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

题意:在n*n的矩阵里,老鼠每一次可以往自身的四个方向走最多k步,且下一次能走的必须比此时的值大,求最大的路径和。

思路:因为每次最多可以走k步,我们可以直接算出每次的四个边界,枚举在范围内可行的点。用记忆化搜索记录以这点开始往后的最大和,依次返回。

代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
int n,k,dir[4][2]={-1,0,1,0,0,-1,0,1};
int num[110][110],book[110][110];
void change(int &x,int &y) //维护边界
{
    if(x<0)
        x=0;
    if(x>=n)
        x=n-1;
    if(y<0)
        y=0;
    if(y>=n)
        y=n-1;
}
int dfs(int x,int y) //记忆化搜索
{
   if(book[x][y])   //如果已经有值的话返回
        return book[x][y];
   int dis[4][2];
   for(int i=0;i<4;i++)  //求这一步可以走的四个边界
   {
       dis[i][0]=x+k*dir[i][0];
       dis[i][1]=y+k*dir[i][1];
       change(dis[i][0],dis[i][1]);//维护边界
   }
   int flag=0;  //标记
   for(int i=0;i<2;i++) //上下  或者  左右
   {
       if(i==0)  // 上下
       {
           for(int tx=dis[0][0];tx<=dis[1][0];tx++) //从这一步的上边界到下边界
           {
               if(tx!=x) //排除这个点
               {
                   if(num[tx][y]>num[x][y])  //下一步的值大于此时的值
                   {
                       int ans=dfs(tx,y)+num[x][y]; //向下传递
                       if(ans>book[x][y])  //维护最大值
                            book[x][y]=ans;
                       flag=1;  //标记出现过
                   }
               }
           }
       }
       else  //同理
       {
           for(int ty=dis[2][1];ty<=dis[3][1];ty++)
           {
               if(ty!=y)
               {
                   if(num[x][ty]>num[x][y])
                   {
                       int ans=dfs(x,ty)+num[x][y];
                       if(ans>book[x][y])
                            book[x][y]=ans;
                       flag=1;
                   }
               }
           }
       }
   }
   if(flag)  //没有出现过的话,返回自己的值
        return book[x][y];
   return num[x][y]; 
}
int main()
{
    while(~scanf("%d%d",&n,&k)&&(n!=-1&&k!=-1))
    {
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                scanf("%d",&num[i][j]);
        memset(book,0,sizeof(book));
        printf("%d\n",dfs(0,0));
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41890797/article/details/82319726