二分 POJ3104 最小化最大值 水题 注意细节

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/DADDY_HONG/article/details/82467241

Drying

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 22433   Accepted: 5676

Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2

太菜了开学了没有很好的做题状态了,太容易wa了。

题目大意:有n件含有不同水分值的衣服,一台烘干机每个单位时间可以烘干k水分(不足k时水分减为0),每个单位时间只能放一件衣服,求最少需要多少单位时间将全部衣服烘干。

很简单的二分水题,但有一些细节需要注意:

1)除以0:直接导致结果->Runtime Error

2)搞清楚向上取整如何写

3)注意考虑情况全面a[i]-x若为负数结果错误

#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn=1e5+10;

int n;
long a[maxn];
long k;

bool cal(long x)
{
    long cnt=0;
    for(int i=0;i<n;++i){
        if(a[i]<=x) continue;   //注!
        cnt+=((a[i]-x-1)/(k-1)+1);
        //注:如果k=1,相当于除0,Runtime Error!//关注数据范围!!!
        //这样写不用余数更聪明
        if(cnt>x) return false;
    }
    return true;
}

int main()
{
    scanf("%d",&n);
    long left=0,right=0,mid;
    for(int i=0;i<n;++i){
        scanf("%ld",&a[i]);
        right=max(right,a[i]);
    }
    scanf("%ld",&k);
    if(k==1){
        printf("%ld\n",right);
        return 0;
    }
    while(left<right){
        mid=(left+right)>>1;
        if(cal(mid)){
            right=mid;
        }
        else{
            left=mid+1;
        }
    }
    printf("%ld\n",right);

    return 0;
}

猜你喜欢

转载自blog.csdn.net/DADDY_HONG/article/details/82467241
今日推荐