中国大学MOOC-陈越、何钦铭-数据结构-2018秋 02-线性结构4 Pop Sequence (25 分) 栈

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

 按照栈给出的原则进行模拟,模拟过程中判断是否超出栈大小的范围,模拟完后栈判断是否为空。 。。

代码如下:
 

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <stack>
using namespace std;
const int maxn=1005;
int a[maxn];
int m,n,k;
stack<int>s;
void init()
{
    while (!s.empty())
        s.pop();
}
int main()
{
    scanf("%d%d%d",&m,&n,&k);
    for (int i=0;i<k;i++)
    {
        for (int ii=1;ii<=n;ii++)
            scanf("%d",&a[ii]);
        int flag=0;
        init();
        for (int j=1,kk=1;j<=n;j++)
        {
            s.push(j);
            if(s.size()>m)
            {
                flag=1;
                break;
            }
            while(!s.empty()&&s.top()==a[kk])
            {
                kk++;
                s.pop();
            }
        }
        if(!s.empty())
            flag=1;
        if(flag)
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/82735169
今日推荐