80 Days

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/lzyws739307453/article/details/82820836

时间限制:1000ms 单点时限:1000ms 内存限制:256MB

题目描述

80 Days is an interesting game based on Jules Verne's science fiction "Around the World in Eighty Days". In this game, you have to manage the limited money and time.

Now we simplified the game as below:

There are n cities on a circle around the world which are numbered from 1 to n by their order on the circle. When you reach the city i at the first time, you will get ai dollars (ai can even be negative), and if you want to go to the next city on the circle, you should pay bi dollars. At the beginning you have c dollars.

The goal of this game is to choose a city as start point, then go along the circle and visit all the city once, and finally return to the start point. During the trip, the money you have must be no less than zero.

Here comes a question: to complete the trip, which city will you choose to be the start city?

If there are multiple answers, please output the one with the smallest number.

输入

The first line of the input is an integer T (T ≤ 100), the number of test cases.

For each test case, the first line contains two integers n and c (1 ≤ n ≤ 106, 0 ≤ c ≤ 109).  The second line contains n integers a1, …, an  (-109 ≤ ai ≤ 109), and the third line contains n integers b1, …, bn (0 ≤ bi ≤ 109).

It's guaranteed that the sum of n of all test cases is less than 106

输出

For each test case, output the start city you should choose.

提示

For test case 1, both city 2 and 3 could be chosen as start point, 2 has smaller number. But if you start at city 1, you can't go anywhere.

For test case 2, start from which city seems doesn't matter, you just don't have enough money to complete a trip.

样例输入

2
3 0
3 4 5
5 4 3
3 100
-3 -4 -5
30 40 50

样例输出

2
-1

解題報告

題意:有n个城市,给出到每个城市的收入和去下一个城市的入门费以及初始的钱数,问从哪个城市出发才能把所有的城市走完,并保证中途的钱数和走到起点的钱数不小于0。

解题思路

直接暴力:用一个循环来控制出发点,二重循环控制走的城市。

#include <stdio.h>
#define N 1000020
int a[N], b[N], c[N];
int main()
{
	int t, n, cn, i, j, temp;
	long long sum;
	scanf("%d", &t);
	while (t--)
	{
		sum = 0;
		scanf("%d%d", &n, &cn);
		for (i = 1; i <= n; i++)
			scanf("%d", &a[i]);
		for (i = 1; i <= n; i++)
		{
			scanf("%d", &b[i]);
			c[i] = a[i] - b[i];
			sum += c[i];
		}
		if (sum + cn < 0)
		{
			printf("-1\n");
			continue;
		}
		for (i = 1; i <= n; i++)
		{
			sum = cn;
			temp = 1;
			for (j = i; j < n + i; j++)
			{
				if (j > n)
					sum += c[j - n];
				else sum += c[j];
				if (sum < 0)
				{
					temp = 0;
					break;
				}
			}
			if (temp)
				break;
		}
		printf("%d\n", i);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/lzyws739307453/article/details/82820836
80