ACM-ICPC 2018 焦作赛区网络预赛G题

Give Candies

  •  1000ms
  •  65536K

There are NN children in kindergarten. Miss Li bought them NN candies. To make the process more interesting, Miss Li comes up with the rule: All the children line up according to their student number (1...N)(1...N), and each time a child is invited, Miss Li randomly gives him some candies (at least one). The process goes on until there is no candy. Miss Li wants to know how many possible different distribution results are there.

Input

The first line contains an integer TT, the number of test case.

The next TT lines, each contains an integer NN.

1 \le T \le 1001≤T≤100

1 \le N \le 10^{100000}1≤N≤10100000

Output

For each test case output the number of possible results (mod 1000000007).

样例输入复制

1
4

样例输出复制

8

题目来源

ACM-ICPC 2018 焦作赛区网络预赛

思路:

这道题很简单,首先我们轻易就看出了答案就是2^(n - 1),但是由于n非常大,直接快速幂肯定是不行的,于是可以进位来求

很明显2^(10n) = (2^n)^10,由于幂次是n - 1,所以不能最后盲目的除以2,可以利用费马小定理离线求出逆元,于是就解出来了

代码:

#include<bits/stdc++.h>
using namespace std;
#define ll long long
const ll mod = (ll)1e9 + 7;
const ll maxn = (ll)1e5 + 10;
const ll inv = 500000004;
char num[maxn];
ll quick(ll a,ll b)
{
    ll res = 1;
    while (b)
    {
        if (b & 1)
            res = res * a % mod;
        a = a * a % mod;
        b >>= 1;
    }
    return res;
}
int main()
{
    int t;
    scanf("%d",&t);
    while (t --)
    {
        scanf("%s",num);
        int len = strlen(num);
        ll ans = 1;
        for (int i = 0;i < len;i ++)
        {
            ans = quick(ans,10);
            ans = ans * quick(2,num[i] - '0') % mod;
        }
        ans = ans * inv % mod;
        printf("%lld\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/cloudy_happy/article/details/82716223
今日推荐