ACM-ICPC 2018 焦作赛区网络预赛A. Magic Mirror(签到题)

Jessie has a magic mirror. 

Every morning she will ask the mirror: 'Mirror mirror tell me, who is the most beautiful girl in the world?' If the mirror says her name, she will praise the mirror: 'Good guy!', but if the mirror says the name of another person, she will assail the mirror: 'Dare you say that again?' 

Today Jessie asks the mirror the same question above, and you are given a series of mirror's answers. For each answer, please output Jessie's response. You can assume that the uppercase or lowercase letters appearing anywhere in the name will have no influence on the answer. For example, 'Jessie' and 'jessie' represent the same person.

Input

The first line contains an integer T(1≤T≤100)T(1≤T≤100), which is the number of test cases.

Each test case contains one line with a single-word name, which contains only English letters. The length of each name is no more than 1515.

Output

For each test case, output one line containing the answer.

样例输入 复制

2
Jessie
Justin

样例输出 复制

Good guy!
Dare you say that again?

 定位很明确了,我就是个翻译呜呜呜

【通过代码】

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        string s;
        cin>>s;
        int len=s.length();
        for(int i=0;i<len;i++)
            	s[i]=tolower(s[i]);
        if(s=="jessie")printf("Good guy!\n");
        else printf("Dare you say that again?\n");
    }
    return 0;
}
扫描二维码关注公众号,回复: 3547266 查看本文章

猜你喜欢

转载自blog.csdn.net/hzyhfxt/article/details/82749000
今日推荐