北京大学OpenJudge 1988 Cube Stacking (并查集)

版权声明:版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_37618760/article/details/81875184

Cube Stacking

Time Limit: 2000MS   Memory Limit: 30000K
Total Submissions: 28148   Accepted: 9879
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

Source

USACO 2004 U S Open

Source   File

#include<iostream>
#include<cstdio>
using namespace std;
#define MAXN 30000
int parent[MAXN+5];
int sum[MAXN+5];
int under[MAXN+5];
int getRoot(int a){
    int t;
    if(parent[a]==a)
        return a;
        t=getRoot(parent[a]);
        under[a]+=under[parent[a]];
        parent[a]=t;
    return parent[a];
}
void Merge(int a,int b){
    int pa=getRoot(a);
    int pb=getRoot(b);
    if(pa==pb)
        return ;
    parent[pb]=pa;
    under[pb]=sum[pa];
    sum[pa]+=sum[pb];
}

int main(){
    int p;
    cin>>p;
    for(int i=0;i<MAXN;i++){
        parent[i]=i;
        sum[i]=1;
        under[i]=0;
    }
    for(int i=0;i<p;i++){
        char s[2];
        scanf("%s",s);
        int a,b;
        if(s[0]=='M'){
            scanf("%d%d",&a,&b);
            Merge(b,a);
        }
        else{
            scanf("%d",&a);
            getRoot(a);
            printf("%d\n",under[a]);
        }
    }
}

猜你喜欢

转载自blog.csdn.net/qq_37618760/article/details/81875184