poj 1088 滑雪(dp)

题目链接:http://poj.org/problem?id=1088

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子 

 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9


一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

遍历一下数组,当遍历到某个点时候,搜索它的上下左右四个点是否满足小于当前点,如果满足的话,继续递归下去进行搜索,递归结束后,
返回上下左右四个点的最大值,然后将最大值 + 1即为当前点的最长下降子序列的值,记录到len数组中,找出len数组的最大值,就是所求;

#pragma GCC optimize(2)
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
const int maxn = 110;
const int inf = 0x3f3f3f3f;
typedef long long ll;
int mp[maxn][maxn], len[maxn][maxn];
int n, m;
int d[4][2] = { 1,0,-1,0,0,1,0,-1 };
int dp(int x, int y)
{
	int s, ms;
	ms = 0;
	if (len[x][y] != 0)
	{
		return len[x][y];
	}
	for (int i = 0; i < 4; i++)
	{
		int tx = x + d[i][0];
		int ty = y + d[i][1];
		if (tx < 1 || ty < 1 || tx>n || ty>m)
		{
			continue;
		}
		if(mp[tx][ty]<mp[x][y])
		{
			s = dp(tx, ty);
			ms = max(s, ms);
		}
	}
	len[x][y] = ms + 1;
	return len[x][y];
}
int main()
{
	//freopen("C://input.txt", "r", stdin);
	scanf("%d%d", &n, &m);
	memset(len, 0, sizeof(len));
	memset(mp, 0, sizeof(mp));
	for (int i = 1; i <= n; i++)
	{
		for (int j = 1; j <= m; j++)
		{
			scanf("%d", &mp[i][j]);
		}
	}
	int Max = -1;
	for (int i = 1; i <= n; i++)
	{
		for (int j = 1; j <= m; j++)
		{
			Max = max(Max, dp(i, j));
		}
	}
	printf("%d\n", Max);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Evildoer_llc/article/details/82976345
今日推荐