HDU 1490

版权声明:如果转载,请注明出处。 https://blog.csdn.net/S_999999/article/details/82958648

非常可乐

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24955    Accepted Submission(s): 9716


 

Problem Description

大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。

 

Input

三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。

 

Output

如果能平分的话请输出最少要倒的次数,否则输出"NO"。

 

Sample Input

 

7 4 3 4 1 3 0 0 0

 

Sample Output

 

NO 3

 

#include<iostream>
using namespace std;
int gcd( int a,int b){
	
	if( b==0)
	  return a;
	return gcd( b , a%b);   
}
int main(void){
	
	int S,N,M;
	while( scanf("%d%d%d",&S,&N,&M)!=EOF&& ( S||N||M)  )
	{ 
		 int ans = S / gcd(N,M);
		 if( ans & 1 )
		 printf("NO\n"); 
		 else printf("%d\n",ans-1); 
	     
	} 
	return 0;
}

猜你喜欢

转载自blog.csdn.net/S_999999/article/details/82958648
hdu