POJ 1789

Truck History

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 34106   Accepted: 13202

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 

1/Σ(to,td)d(to,td)


where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

<span style="color:#000000">4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0
</span>

Sample Output

<span style="color:#000000">The highest possible quality is 1/3.
</span>

Source

CTU Open 2003

大致题意:

用一个7位的string代表一个编号,两个编号之间的distance代表这两个编号之间不同字母的个数。一个编号只能由另一个编号“衍生”出来,代价是这两个编号之间相应的distance,现在要找出一个“衍生”方案,使得总代价最小,也就是distance之和最小。

例如有如下4个编号:

aaaaaaa

baaaaaa

abaaaaa

aabaaaa

显然的,第二,第三和第四编号分别从第一编号衍生出来的代价最小,因为第二,第三和第四编号分别与第一编号只有一个字母是不同的,相应的distance都是1,加起来是3。也就是最小代价为3。

解题思路:

问题可以转化为最小代价生成树的问题。因为每两个结点之间都有路径,所以是完全图。 

此题的关键是将问题转化为最小生成树的问题。

每一个编号为图的一个顶点,顶点与顶点间的编号差即为这条边的权值,

题目所要的就是我们求出最小生成树来。这里我用prim算法来求最小生成树。

代码:

//Memory Time 
//15688K 344MS 
 
#include<iostream>
#include<string>
using namespace std;
 
const int inf=10;          //无穷大(两点间边权最大为7)
const int large=2001;
 
int n;  //truck types
char str[large][8];
int dist[large][large]={0};
 
/*Compute Weight*/
 
int weight(int i,int j)     //返回两个字符串中不同字符的个数(返回边权)
{
	int w=0;
	for(int k=0;k<7;k++)
		if(str[i][k]!=str[j][k])
			w++;
	return w;
}
 
/*Prim Algorithm*/
 
int prim(void)
{
	int s=1;       //源点(最初的源点为1)
	int m=1;       //记录最小生成树的顶点数
	bool u[large]; //记录某顶点是否属于最小生成树
	int prim_w=0;  //最小生成树的总权值
	int min_w;     //每个新源点到其它点的最短路
	int flag_point;
	int low_dis[large];  //各个源点到其它点的最短路
 
	memset(low_dis,inf,sizeof(low_dis));
	memset(u,false,sizeof(u));
	u[s]=true;
 
	while(1)
	{
		if(m==n)      //当最小生成树的顶点数等于原图的顶点数时,说明最小生成树查找完毕
			break;
 
		min_w=inf;
		for(int j=2;j<=n;j++)
		{
			if(!u[j] && low_dis[j]>dist[s][j])
				low_dis[j] = dist[s][j];
			if(!u[j] && min_w>low_dis[j])
			{
				min_w=low_dis[j];
				flag_point=j;      //记录最小权边中不属于最小生成树的点j
			}
		}
		s=flag_point;       //顶点j与旧源点合并
		u[s]=true;          //j点并入最小生成树(相当于从图上删除j点,让新源点接替所有j点具备的特征)
		prim_w+=min_w;      //当前最小生成树的总权值
		m++;                
	}
	return prim_w;
}
 
int main(void)
{
	int i,j;
 
	while(cin>>n && n)
	{
		/*Input*/
		
		for(i=1;i<=n;i++)
			cin>>str[i];
 
		/*Structure Maps*/
 
		for(i=1;i<=n-1;i++)
			for(j=i+1;j<=n;j++)
				dist[i][j]=dist[j][i]=weight(i,j);
 
		/*Prim Algorithm & Output*/
 
		cout<<"The highest possible quality is 1/"<<prim()<<'.'<<endl;
 
	}
	return 0;
}

同思路的代码:

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std ;
const int maxn = 2010 ;
const int inf = 0x3f3f3f3f  ;
char str[maxn][10] ;
int map[maxn][maxn] ;
int vis[maxn] ;
int dis[maxn] ;
int n ;
int prime()
{
    for(int i = 2;i <= n;i++)
    dis[i] = inf ;
    dis[1] = 0 ;
    memset(vis , 0 ,sizeof(vis)) ;
    int ans = 0 ;
    while(1)
    {
        int mi = inf ;int pos ;
        for(int i = 1;i <= n;i++)
        if(!vis[i] && dis[i] < mi)
        mi = dis[pos = i] ;
        if(mi == inf)break;
        vis[pos] = 1;
        ans += mi ;
        for(int j = 1;j <= n ;j++)
        dis[j] = min(dis[j] , map[pos][j]) ;
    }
    return ans ;
}
int main()
{
    while(scanf("%d" , &n) && n)
    {
        for(int i = 1;i <= n;i++)
        {
            scanf("%s" , &str[i][1]) ;
            for(int j = 1;j <= i;j++)
            {
                int sum = 0 ;
                for(int k = 1;k <= 7 ;k++)
                if(str[i][k] != str[j][k])
                sum++ ;
                map[i][j] = map[j][i] = sum ;
            }
        }
        int ans = prime() ;
        printf("The highest possible quality is 1/%d.\n" , ans) ;
    }
    return 0 ;
}

猜你喜欢

转载自blog.csdn.net/qq_40421671/article/details/82986945