卡特兰数(JAVA大数)Buy the Ticket

Description

The “Harry Potter and the Goblet of Fire” will be on show in the next few days. As a crazy fan of Harry Potter, you will go to the cinema and have the first sight, won’t you?

Suppose the cinema only has one ticket-office and the price for per-ticket is 50 dollars. The queue for buying the tickets is consisted of m + n persons (m persons each only has the 50-dollar bill and n persons each only has the 100-dollar bill).

Now the problem for you is to calculate the number of different ways of the queue that the buying process won’t be stopped from the first person till the last person.
Note: initially the ticket-office has no money.

The buying process will be stopped on the occasion that the ticket-office has no 50-dollar bill but the first person of the queue only has the 100-dollar bill.

Input

The input file contains several test cases. Each test case is made up of two integer numbers: m and n. It is terminated by m = n = 0. Otherwise, m, n <=100.

Output

For each test case, first print the test number (counting from 1) in one line, then output the number of different ways in another line.

Sample Input

3 0
3 1
3 3
0 0

Sample Output

Test #1:
6
Test #2:
18
Test #3:
180
m人有50元,n人有100元,收营员要拿收到的50找给100,如果没有50就停止,求符合条件序列的个数。

m < n 时 不存在合法方案
当 m >= n 时
合法排列有定有 m!×n!×C(m,m+n)种排法
而有 m!×n!×C(m+1,m+n) 非法排法 (从有1个50的前边至少多1个100)
所以有合法排法 m!×n!×(C(m,m+n)−C(m+1,m+n))= (m+n)!×(m−n+1)/(m+1)

package Main;

import java.math.BigDecimal;
import java.math.BigInteger;
import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		BigDecimal sum;
		
		while(cin.hasNext())
		{
			int m,n,cs=1;
			sum = new BigDecimal("1");
			m=cin.nextInt();
			n=cin.nextInt();
			if(m==0&&n==0)
				break;	
			System.out.println("Test #" + (cs++) +":");
			if(n<=m)
			{
				for(int i=1;i<=(m+n); i++)
				{
					sum=sum.multiply(new BigDecimal(i));
				}	
				sum=sum.multiply(new BigDecimal(m+1-n));
				sum=sum.divide(new BigDecimal(m+1));
				System.out.println(sum);
			}
			else
				System.out.println("0");
				
		}
	}
}

猜你喜欢

转载自blog.csdn.net/qq_38984851/article/details/83187498