小希的

小希的迷宫-杭电地址

					小希的迷宫

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 65877 Accepted Submission(s): 20676

problem Description
上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。

在这里插入图片描述

Input 输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
整个文件以两个-1结尾。

Output 对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。

Sample Input
6 8 5 3 5 2 6 4 5 6 0 0

8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0

3 8 6 8 6 4 5 3 5 6 5 2 0 0

-1 -1
Sample Output
Yes
Yes
No

解题:利用并查集判断是否存在环,如果a和b已经在前面的输入中有了一条路径,当输入a和b时说明又再加一条路径,则此时不行
利用set来保存有哪些号码

注意:对于一组测试值输入0 0也要输出"Yes” /不要问为什么,就是这样规定的

#include<iostream>
#include<set>
using namespace std;
int parent[100005];
int find(int x)
{
 if(x != parent[x])parent[x] = find(parent[x]);
 return parent[x];
}
void uni(int x1,int x2)
{
 parent[x1] = x2;
}
int main()
{
 int a,b;
 while(cin >> a >> b)
 {
  if(a == -1 && b == -1)
  {
   break;
  }
  if(a == 0 && b == 0)
  {
   cout << "Yes" << endl;
   continue;
  }
  set<int>shuzu;
  shuzu.insert(a);
  shuzu.insert(b);
  for(int i = 0; i < 100005;i++)parent[i] = i;
  int flag = true;
  
  int x1 = find(a);
  int x2 = find(b);
  if(x1 == x2)flag = false;
  else uni(x1,x2);
  while(cin >> a >> b)
  {
   if(a == 0 && b == 0)break;
   else
   {
    shuzu.insert(a);
    shuzu.insert(b);
    int x3 = find(a);
    int x4 = find(b);
    if(x3 == x4)flag = false;
    else uni(x3,x4);
   }
  }
  set<int>::iterator it = shuzu.begin();
  int res = 0;
  while(it != shuzu.end())
  {
   if(parent[*it] == *it)res++;
   it++;
  } 
  if(res != 1)flag = false;
  if(flag)cout << "Yes" << endl;
  else cout << "No" << endl;
 }
} 

猜你喜欢

转载自blog.csdn.net/weixin_40936298/article/details/82988499
今日推荐