Raid POJ - 3714 分治求最近点对

After successive failures in the battles against the Union, the Empire retreated to its last stronghold. Depending on its powerful defense system, the Empire repelled the six waves of Union's attack. After several sleepless nights of thinking, Arthur, General of the Union, noticed that the only weakness of the defense system was its energy supply. The system was charged by N nuclear power stations and breaking down any of them would disable the system.

The general soon started a raid to the stations by N special agents who were paradroped into the stronghold. Unfortunately they failed to land at the expected positions due to the attack by the Empire Air Force. As an experienced general, Arthur soon realized that he needed to rearrange the plan. The first thing he wants to know now is that which agent is the nearest to any power station. Could you, the chief officer, help the general to calculate the minimum distance between an agent and a station?

Input

The first line is a integer T representing the number of test cases.
Each test case begins with an integer N (1 ≤ N ≤ 100000).
The next N lines describe the positions of the stations. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the station.
The next following N lines describe the positions of the agents. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the agent.  

Output

For each test case output the minimum distance with precision of three decimal placed in a separate line.

Sample Input

2
4
0 0
0 1
1 0
1 1
2 2
2 3
3 2
3 3
4
0 0
0 0
0 0
0 0
0 0
0 0
0 0
0 0

Sample Output

1.414
0.000

很明显O(N^2)的复杂度无法接受,考虑分治解决;

对于每一个区间同样进行分治下去;

那么合并区间时,只需要看我们此时 ans 半径内的点;

然后将y轴方向排序,暴力解决;

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<set>
#include<vector>
#include<queue>
#include<bitset>
#include<ctime>
#include<deque>
#include<stack>
#include<functional>
#include<sstream>
//#include<cctype>
//#pragma GCC optimize("O3")
using namespace std;
#define maxn 200004
#define inf 0x3f3f3f3f
#define INF 999999999999
#define rdint(x) scanf("%d",&x)
#define rddoub(x) scanf("%lf",&x)
#define rdllt(x) scanf("%lld",&x)
typedef long long  ll;
typedef unsigned long long ull;
typedef unsigned int U;
#define ms(x) memset((x),0,sizeof(x))
const int mod = 1e9 + 7;
#define Mod 20100403
#define sq(x) (x)*(x)
#define eps 1e-7
typedef pair<int, int> pii;
#define pi acos(-1.0)
#define REP(i,n) for(int i=0;i<(n);i++)

inline int rd() {
	int x = 0;
	char c = getchar();
	bool f = false;
	while (!isdigit(c)) {
		if (c == '-') f = true;
		c = getchar();
	}
	while (isdigit(c)) {
		x = (x << 1) + (x << 3) + (c ^ 48);
		c = getchar();
	}
	return f ? -x : x;
}

ll gcd(ll a, ll b) {
	return b == 0 ? a : gcd(b, a%b);
}
ll sqr(ll x) { return x * x; }

struct node {
	double x, y;
	int Set;
}a[maxn],b[maxn];

bool cmpx(node x, node y) {
	return x.x < y.x;
}
bool cmpy(node a, node b) {
	return a.y < b.y;
}

double dis(node a, node b) {
	if (a.Set == b.Set)return inf;
	return sqrt(1.0*(a.x - b.x)*(a.x - b.x) + (a.y - b.y)*(a.y - b.y));
}

double partition(int l, int r) {
	if (l == r)return inf;
	int mid = (l + r) >> 1;
	double ans = inf;	
	ans = min(partition(l, mid), partition(mid + 1, r));
    int cnt = 0;
	for (int i = l; i <= r; i++) {
		if (fabs(a[i].x - a[mid].x) <= ans)b[++cnt] = a[i];
	}
	sort(b + 1, b + cnt + 1, cmpy);
	for (int i = 1; i <= cnt; i++) {
		for (int j = i + 1; j <= cnt; j++) {
			if (b[j].y - b[i].y > ans) {
				break;
			}
			ans = min(ans, dis(b[i], b[j]));
		}
	}
	return ans;
}
int n;

int main()
{
	//ios::sync_with_stdio(false);
	int T; rdint(T);
	while (T--) {
		rdint(n); ms(a); 
		for (int i = 1; i <= n; i++) {
			rddoub(a[i].x); rddoub(a[i].y); a[i].Set = 0;
		}
		for (int i = 1; i <= n; i++) {
			rddoub(a[i + n].x); rddoub(a[i + n].y); a[i + n].Set = 1;
		}
		sort(a + 1, a + 2 * n + 1, cmpx);
		printf("%.3lf\n", partition(1, 2 * n)*1.0);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40273481/article/details/83152901