find the nth digit HDU - 1597

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/liar771/article/details/54137042

假设: 
S1 = 1 
S2 = 12 
S3 = 123 
S4 = 1234 
......... 
S9 = 123456789 
S10 = 1234567891 
S11 = 12345678912 
............ 
S18 = 123456789123456789 
.................. 
现在我们把所有的串连接起来 
S = 1121231234.......123456789123456789112345678912......... 
那么你能告诉我在S串中的第N个数字是多少吗? 
Input输入首先是一个数字K,代表有K次询问。 
接下来的K行每行有一个整数N(1 <= N < 2^31)。 Output对于每个N,输出S中第N个对应的数字. 
Sample Input
6
1
2
3
4
5
10
Sample Output
1
1
2
1
2
4

纯数学题,定位到m所在的si,分类取余得出

#include<stdio.h>
#include<math.h>
#include<ctype.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int main()
{
    long long t,n,m;
    scanf("%lld",&t);
    while(t--)
    {
        scanf("%lld",&m);
        n=(int)floor((sqrt(double(8*m+1))-1)/2.0);
        m-=n*(n+1)/2;
        if(m==0)
            m=n%9?n%9:9;
        else
            m=m%9?m%9:9;
        printf("%lld\n",m);
    }
}


猜你喜欢

转载自blog.csdn.net/liar771/article/details/54137042