HDU3001 送外卖(三进制状压DP)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Feynman1999/article/details/82316649

problem

After coding so many days,Mr Acmer wants to have a good rest.So travelling is the best choice!He has decided to visit n cities(he insists on seeing all the cities!And he does not mind which city being his start station because superman can bring him to any city at first but only once.), and of course there are m roads here,following a fee as usual.But Mr Acmer gets bored so easily that he doesn’t want to visit a city more than twice!And he is so mean that he wants to minimize the total fee!He is lazy you see.So he turns to you for help.

Input

There are several test cases,the first line is two intergers n(1<=n<=10) and m,which means he needs to visit n cities and there are m roads he can choose,then m lines follow,each line will include three intergers a,b and c(1<=a,b<=n),means there is a road between a and b and the cost is of course c.Input to the End Of File.

Output

Output the minimum fee that he should pay,or -1 if he can’t find such a route.

Sample Input

2 1
1 2 100
3 2
1 2 40
2 3 50
3 3
1 2 3
1 3 4
2 3 10

Sample Output

100
90
7

思路

给图的权值

走过图上所有点,要求经过每个点不超过两次的最小总花费
状压三进制即可

时间复杂度 O ( 3 n n 2 )

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int inf=0x3f3f3f3f;

const int N=11;
int dp[int(pow(3,N))][N];//最后一次在哪个点
int d[N][N];
int help[N];
int wei[int(pow(3,N))][N];

void init()
{
    help[0]=1;
    for(int i=1;i<=10;++i) help[i]=help[i-1]*3;
    wei[0][0]=0;
    for(int s=0;s<=help[10];++s){
        int tp=s;
        int num=0;
        while(tp){
            wei[s][num++]=tp%3;
            tp/=3;
        }
    }
}

int main()
{
    init();
    int n,m;
    //cout<<wei[4][1]<<endl;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        memset(d,inf,sizeof(d));
        memset(dp,inf,sizeof(dp));
        while(m--){
            int u,v,w;
            scanf("%d %d %d",&u,&v,&w);
            if(d[u][v]>w){
                d[u][v]=w;
                d[v][u]=w;
            }
            //cout<<u<<" "<<v<<" "<<endl;
        }
        int up=help[n];
        int ans=inf;
        //从所有走了1次和2次的可能里找最小的
        for(int i=0;i<n;++i) dp[help[i]][i]=0;
        for(int s=0;s<up;++s){
            bool flag=true;
            for(int k=0;k<n;++k){//k->j
                if(wei[s][k]==0) {flag=false;continue;}//如果最后flag为true则走完了所有点
                if(dp[s][k]==inf) continue;//没有走下去的必要了
                //if(s==9 && k==2) cout<<"ddd"<<endl;
                for(int j=0;j<n;++j){
                    if(wei[s][j]==2) continue;//走过两次了
                    int tp=s+help[j];
                    //if(s==9 && k==2 && j==1) cout<<"ddd"<<dp[tp][j]<<endl;
                    dp[tp][j]=min(dp[tp][j],dp[s][k]+d[k+1][j+1]);
                }
            }
            if(flag){
                for(int k=0;k<n;++k) {ans=min(ans,dp[s][k]);}// if(dp[s][k]==0) cout<<s<<" "<<k<<endl;}
            }
        }
        if(ans>=inf) cout<<-1<<endl;
        else cout<<ans<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Feynman1999/article/details/82316649
今日推荐