Let's Chat(ZOJ)

                                                          Let's Chat

ACM (ACMers' Chatting Messenger) is a famous instant messaging software developed by Marjar Technology Company. To attract more users, Edward, the boss of Marjar Company, has recently added a new feature to the software. The new feature can be described as follows:

If two users, A and B, have been sending messages to each other on the last m consecutive days, the "friendship point" between them will be increased by 1 point.

More formally, if user A sent messages to user B on each day between the (i - m + 1)-th day and the i-th day (both inclusive), and user B also sent messages to user A on each day between the (i - m + 1)-th day and the i-th day (also both inclusive), the "friendship point" between A and B will be increased by 1 at the end of the i-th day.

Given the chatting logs of two users A and B during n consecutive days, what's the number of the friendship points between them at the end of the n-th day (given that the initial friendship point between them is 0)?

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 10), indicating the number of test cases. For each test case:

The first line contains 4 integers n (1 ≤ n ≤ 109), m (1 ≤ m ≤ n), x and y (1 ≤ x, y ≤ 100). The meanings of n and m are described above, while x indicates the number of chatting logs about the messages sent by A to B, and y indicates the number of chatting logs about the messages sent by B to A.

For the following x lines, the i-th line contains 2 integers la, i and ra, i (1 ≤ la, i ≤ ra, i ≤ n), indicating that A sent messages to B on each day between the la, i-th day and the ra, i-th day (both inclusive).

For the following y lines, the i-th line contains 2 integers lb, i and rb, i (1 ≤ lb, i ≤ rb, i ≤ n), indicating that B sent messages to A on each day between the lb, i-th day and the rb, i-th day (both inclusive).

It is guaranteed that for all 1 ≤ i < x, ra, i + 1 < la, i + 1 and for all 1 ≤ i < y, rb, i + 1 < lb, i + 1.

Output

For each test case, output one line containing one integer, indicating the number of friendship points between A and B at the end of the n-th day.

Sample Input

2
10 3 3 2
1 3
5 8
10 10
1 8
10 10
5 3 1 1
1 2
4 5

Sample Output

3
0

Hint

For the first test case, user A and user B send messages to each other on the 1st, 2nd, 3rd, 5th, 6th, 7th, 8th and 10th day. As m = 3, the friendship points between them will be increased by 1 at the end of the 3rd, 7th and 8th day. So the answer is 3.

题目链接:

https://vjudge.net/problem/ZOJ-3961

题意描述:

A向B发信息的时间段有x个,B向A发信息的时间段有y个,他们连续互相发信息达到m天后会增加亲密度,亲密度的多少取决于连续发信息超过m的天数,如果刚好是m天,则亲密度增加1,求最终的亲密度

解题思路:

把A向B发信息的时间段存到一个结构体里,把B向A发信息的时间段也存到一个结构体里,然后让两个结构体两重循环相比较,如果重叠的部分(len)大于等于m则亲密度就增加len-m+1

程序代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
struct data{
	int l;
	int r;
};

int main()
{
	int i,j,T,n,m,x,y,L,R,len,sum;
	data X[110],Y[110];
	
	scanf("%d",&T);
	while(T--)
	{
		sum=0;
		scanf("%d%d%d%d",&n,&m,&x,&y);
		for(i=1;i<=x;i++)
			scanf("%d%d",&X[i].l,&X[i].r);
		for(i=1;i<=y;i++)
			scanf("%d%d",&Y[i].l,&Y[i].r);
		for(i=1;i<=x;i++)
		{
			for(j=1;j<=y;j++)
			{
				L=max(X[i].l,Y[j].l);
				R=min(X[i].r,Y[j].r);
				len=R-L+1;
				if(len>=m)
					sum+=(len-m+1);
			}
		}
		printf("%d\n",sum);
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/HeZhiYing_/article/details/83379857