02-线性结构4 Pop Sequence

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N(the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

#include<stdio.h>
#include<stdlib.h>
typedef int ElemType;
typedef struct Stack {
	ElemType *data;
	int top;
}NodeStack,*qStack;


int CreateStack(qStack *q, int number);
int Add(qStack *q, ElemType X, int number);

ElemType Delet(qStack *q);


int main()
{	
	int X, Y, Z;
	scanf("%d %d %d", &X, &Y, &Z);
	int **a = (int **)malloc(sizeof(ElemType *)*Z);
	for (int i = 0;i < Z;i++) {
		a[i] = (int *)malloc(sizeof(ElemType)*Y);
	}
	for (int i = 0;i <Z;i++) {
		for (int j = 0;j < Y;j++) {
			scanf("%d", &a[i][j]);
		}
	}
	for (int i = 0;i < Z;i++) {
		int Aold = 1, Anow = 0, number = 0;
		qStack q = NULL;
		CreateStack(&q, X);
		for (int j = 0;j < Y;j++) {
			Anow = a[i][j];
			if (Anow >= Aold) {
				while (Aold <= Anow) {
					if (Add(&q, Aold, X) != 1) {
						break;
					}
					Aold++;
				}
				number = Delet(&q);
			}
			else {
				number = Delet(&q);
			}
			if (number != Anow) {
				printf("NO");
				break;
			}
		}
		if (number == Anow) {
			printf("YES");
		}
		free(q);
		if (i != Z - 1) {
			printf("\n");
		}
	}
    return 0;
}

int CreateStack(qStack *q,int number) {
	int states = 0;
	if (*q == NULL) {
		*q = (NodeStack*)malloc(sizeof(NodeStack));
		(*q)->data = (ElemType*)malloc(sizeof(ElemType)*number);
		(*q)->top = -1;
		states = 1;
	}
	return states;
}

int Add(qStack *q, ElemType X,int number) {
	int states = 0;
	if (*q) {
		if ((*q)->top != number - 1) {
			(*q)->top++;
			(*q)->data[(*q)->top]=X;
			states = 1;
		}
	}
	return states;
}

ElemType Delet(qStack *q) {
	ElemType X = -1;
	if (*q) {
		if ((*q)->top != -1) {
			X = (*q)->data[(*q)->top];
			(*q)->top--;
		}
	}
	return X;
}








猜你喜欢

转载自blog.csdn.net/qq_29718605/article/details/80262149