POJ 1988 Cube Stacking (并查集)

版权声明:From: http://blog.csdn.net/tju_tahara https://blog.csdn.net/TJU_Tahara/article/details/79401430
ACM ICPC 2018 World Finals
Language:
Cube Stacking
Time Limit: 2000MS   Memory Limit: 30000K
Total Submissions: 26668   Accepted: 9350
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

Source


很基础的带权并查集, 只要维护好当前的深度, 这一堆一共有多少个方块就可以了。



#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>

#define MAX 30030

struct node{
	int fa, dep, sum;
}m_arr[MAX];


void init(){
	int i;
	for(i = 0; i < MAX; i++){
		m_arr[i].fa = i;
		m_arr[i].dep = 0;
		m_arr[i].sum = 1;
	}
}

int get(int num){
	int tmp = num;
	while(m_arr[num].fa != num){
		num = m_arr[num].fa;
		m_arr[tmp].dep += m_arr[num].dep;
	}
	m_arr[tmp].fa = num;
	return num;
};


void merg(int a, int b){
	int fa, fb;
	fa = get(a);
	fb = get(b);
	if(fa != fb){
		m_arr[fa].dep = m_arr[fb].sum;
		m_arr[fa].fa = fb;
		m_arr[fb].sum = m_arr[fb].sum + m_arr[fa].sum;
	}
}



int main()
{
	int num, i, a, b;
	char ord;
	scanf("%d", &num);
	init();
	for(i = 0; i < num; i++){
		getchar();
		scanf("%c", &ord);
		if(ord == 'M'){
			scanf("%d%d", &a, &b);
			merg(a, b);
		}
		else{
			scanf("%d", &a);
			get(a);
			printf("%d\n", m_arr[a].dep);
		}
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/TJU_Tahara/article/details/79401430