HDU 5876 Sparse Graph(补图 最短路 BFS map)

版权声明:From: http://blog.csdn.net/tju_tahara https://blog.csdn.net/TJU_Tahara/article/details/52549415

Sparse Graph

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1574    Accepted Submission(s): 553


Problem Description
In graph theory, the  complement of a graph  G is a graph  H on the same vertices such that two distinct vertices of  H are adjacent if and only if they are  not adjacent in  G

Now you are given an undirected graph  G of  N nodes and  M bidirectional edges of  unit length. Consider the complement of  G, i.e.,  H. For a given vertex  S on  H, you are required to compute the shortest distances from  S to all  N1 other vertices.
 

Input
There are multiple test cases. The first line of input is an integer  T(1T<35) denoting the number of test cases. For each test case, the first line contains two integers  N(2N200000) and  M(0M20000). The following  M lines each contains two distinct integers  u,v(1u,vN) denoting an edge. And  S (1SN) is given on the last line.
 

Output
For each of  T test cases, print a single line consisting of  N1 space separated integers, denoting shortest distances of the remaining  N1 vertices from  S (if a vertex cannot be reached from S, output ``-1" (without quotes) instead) in ascending order of vertex number.
 

Sample Input
 
  
1 2 0 1
 

Sample Output
 
  
1
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5877  5875  5874  5873  5872

题意:
图的补图的某一点到所有点的最短路,分别输出。

这次比赛真的是水过去了,状态非常差。这道题用裸BFS来解最短路也是第一次遇到。题做多了脑子就死了。比较裸的bfs,手懒脑子又懒的直接用map储存原来有的边,假如map[a][b]为0,那么补图就为1, 遍历所有可到达的顶点即可。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <map>
#define MAXV 200010
#define INF 0x3f3f3f3f
using namespace std;
typedef long long ll;

map<int, bool> ma[MAXV];
int dist[MAXV];
bool oc[MAXV];
void clear(int v){
    v += 3;
    memset(oc, 0, sizeof(oc));
    for(int i = 1; i < v; i++){
        ma[i].clear();
        dist[i] = INF;
    }
}

void bfs(int s, int v){
    int i, now, nxt;
    queue<int> que1;
    queue<int> que3;
    queue<int> que2;
    for(i = 1; i <= v; i++)
        que1.push(i);
    que2.push(s);
    oc[s] = 1;
    dist[s] = 0;
    while((!que1.empty()) && (!que2.empty())){
        now = que2.front();
        que2.pop();
        while(!que1.empty()){
            nxt = que1.front();
            que1.pop();
            if(now == nxt) continue;
            if(ma[now][nxt]){
                que3.push(nxt); continue;
            }
            if(dist[nxt] > dist[now] + 1)
              dist[nxt] = dist[now] + 1;
            if(!oc[nxt]){
                que2.push(nxt);
                oc[nxt] = 1;
            }
        }
        while(!que3.empty()){
            nxt = que3.front();
            que3.pop();
            que1.push(nxt);
        }
    }
}

void print(int v){
    int i, cnt;
    cnt = 2;    i = 1;
    while(cnt < v){
        if(dist[i] == 0){
            ++i; continue;
        }
        else if(dist[i] == INF){
            printf("-1 "); ++i; ++cnt;
        }
        else{
            printf("%d ", dist[i]);
            ++i; ++cnt;
        }
    }
    while(cnt == v){
        if(dist[i] == 0){
            ++i; continue;
        }
        else if(dist[i] == INF){
            printf("-1\n"); ++i; cnt++;
        }
        else{
            printf("%d\n", dist[i]);
            ++i; ++cnt;
        }
    }
}

int main()
{
    int casen, v, e, i, s, t;
    scanf("%d", &casen);
    while(casen--){
        scanf("%d%d", &v, &e);
        clear(v);
        for(i = 0; i < e; i++){
            scanf("%d%d", &s, &t);
            ma[t][s] = ma[s][t] = 1;
        }
        scanf("%d", &s);
        bfs(s, v);
        print(v);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/TJU_Tahara/article/details/52549415
今日推荐