POJ 2299 Ultra QuickSort

Ultra-QuickSort

| Time Limit: 7000MS |   | Memory Limit: 65536K |
| Total Submissions: 72479 |   | Accepted: 27197 |

Description


In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 

9 1 0 5 4 ,

Ultra-QuickSort produces the output 

0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source

Waterloo local 2005.02.05

题解

快速排序模板题,代码如下:

#include <iostream>
#include <vector>
using namespace std ;

long long merge(vector<long long> &a , long long l , long long mid , long long r){
    long long help[r-l+1] ;
    long long k = 0 ;
    long long p1 = l , p2 = mid + 1 ;
    long long sum = 0 ;
    while ( p1 <= mid && p2 <= r ){
        sum += a[p1] > a[p2] ? (r-p2+1) : 0 ;
        help[k++] = a[p1] > a[p2] ? a[p1++] : a[p2++] ;
    }
    while ( p1 <= mid ){
        help[k++] = a[p1++] ;
    }
    while ( p2 <= r ){
        help[k++] = a[p2++] ;
    }
    for ( long long i = 0 ; i < r-l+1 ; i ++ ){
        a[i+l] = help[i] ;
    }
    return sum ;
}

long long merge_sort(vector<long long> &a , long long l , long long r){
    if ( l == r ) return 0 ;
    long long mid = l + (r-l) / 2 ;
    return merge_sort(a,l,mid) + merge_sort(a,mid+1,r) + merge(a,l,mid,r) ;
}

int main(){
    long long n ;
    while ( cin >> n && n ){
        vector<long long> a ;
        for ( long long i = 0 ; i < n ; i ++ ){
            long long x ;
            cin >> x ;
            a.push_back(x) ;
        }
        cout << merge_sort(a,0,a.size()-1) << endl ;
    }
    return 0 ;
}

猜你喜欢

转载自www.cnblogs.com/Cantredo/p/9893183.html