统计难题(字典树)

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀). 

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串. 

注意:本题只有一组测试数据,处理到文件结束. 

Output

对于每个提问,给出以该字符串为前缀的单词的数量. 

Sample Input

banana
band
bee
absolute
acm

ba
b
band
abc

Sample Output

2
3
1
0
#include<iostream>
#include<cmath>
#include<string.h>
#include<algorithm>
#include<cstdio>
#include<queue>
#include<set>
#include<map>
#include<vector>
#include<string>
using namespace std;
typedef long long ll;

struct Trie{
    int v;
    Trie *next[26];
};
Trie root;
void createTrie(char *str)//建立字典树
{
    int len = strlen(str);
    Trie *p = &root,*q;
    for(int i = 0;i<len;i++)
    {
        int id = str[i] - 'a';
        if(p->next[id] == NULL)
        {
            q=(Trie *)malloc(sizeof(root));//申请一块新内存
            q->v = 1;
            for(int j = 0;j<26;j++)
            q->next[j] = NULL;
            p->next[id] = q;
            p = p->next[id];
        }
        else{
            p->next[id]->v++;
            p = p->next[id];
        }
    }
}
int findTrie(char *str)//在字典树中查询
{
    int len = strlen(str);
    Trie *p = &root;
    for(int i = 0; i< len;i++)
    {
        int id = str[i] - 'a';
        p = p->next[id];
        if(p == NULL)
            return 0;
    }
    return p->v;
}
int main(){
    char str[15];
    for(int i = 0;i<26;i++)
    {
        root.next[i] = NULL;
    }
    while(gets(str)&&str[0]!='\0')
    {
        createTrie(str);
    }
    while(cin>>str)
    {
        int ans = findTrie(str);
        cout<<ans<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41988545/article/details/83447080
今日推荐