POJ 1088 滑雪 (搜索)

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子

 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9


一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

 因为有四个方向可以走动,所以需要求出四个方向上的最优解,即四个方向分别遍历,求出最大的步数。

 从数组第一个元素开始到最后一个元素进行搜索。
 代码如下:

扫描二维码关注公众号,回复: 4028107 查看本文章
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=105;
int r,c;
int h[maxn][maxn];
int len[maxn][maxn];
int hx,hy;
int Max=-0x3f3f3f3f;
int loc[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
int dfs (int x,int y)
{
    if(len[x][y]!=0)
    {
        return len[x][y];
    }
    int step;
    int tx,ty;
    int Maxx=1;
    for (int i=0;i<4;i++)
    {
        tx=x+loc[i][0];
        ty=y+loc[i][1];
        if(tx>0&&tx<=r&&ty>0&&ty<=c&&h[x][y]>h[tx][ty])
        {
            step=dfs(tx,ty)+1;
            Maxx=max(Maxx,step);
        }
    }
    return len[x][y]=Maxx;
}
int main ()
{
    scanf("%d%d",&r,&c);
    for (int i=1;i<=r;i++)
    {
        for (int j=1;j<=c;j++)
        {
            scanf("%d",&h[i][j]);
        }
    }
    memset (len,0,sizeof(len));
    for (int i=1;i<=r;i++)
    {
        for (int j=1;j<=c;j++)
        {
            Max=max(Max,dfs(i,j));
        }
    }
    printf("%d\n",Max);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/83757121