2602 :Bone Collector

简单01背包:

 2602

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
 
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
 
  
14

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#define M 1005
int dp[M];
int v[M], w[M], W, N;  // value  weight 
using namespace std; 
void bag01 (int v, int w) {
	for (int i = W; i >= w; i--) {
		dp[i] = max(dp[i - w] + v, dp[i]);
	}
}

int main() {
	int T;
	cin >> T;
	while (T--) {
		cin >> N >> W;
		memset(dp, 0, sizeof(dp));
		memset(v, 0, sizeof(v));
		memset(w, 0, sizeof(w));
		for (int i = 0; i < N; i++) {
			cin >> v[i];	
		}
		for (int i = 0; i < N; i++) {
			cin >> w[i];	
		}
		for (int i = 0; i < N; i++) {
			bag01(v[i], w[i]);	
		}
		cout << dp[W] << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Y_AOZHEN/article/details/80044208
今日推荐