HDU 3746 Cyclic Nacklace (KMP:补齐循环节)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/sdz20172133/article/details/84487252

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16284    Accepted Submission(s): 6747


 

Problem Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:


Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.  

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).

 

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

 

Sample Input

 

3 aaa abca abcde

 

Sample Output

 

0 2 5

 

Author

possessor WC

 

Source

HDU 3rd “Vegetable-Birds Cup” Programming Open Contest

 

Recommend

lcy



算法分析:

题意:

 给你一个串,要你在串头或尾添加最少的字符,使得该串至少有2个循环节,问你最少需要加几个字符.

分析:

我们首先推出一个重要的性质len-next[i]为此字符串s[1...i]的最小循环节(i为字符串的结尾)的长度,另外如果len%(len-next[i])==0,此字符串的最小周期就为len/(len-next[i]);

分析:poj 1961 Period                  (KMP+最小循环节)

所以我们可以排除一种情况,如果len/(len-next[i])==0,答案为0;

如果len/(len-next[i])不为0呢,还是那一个重要性质:

重要的性质len-next[i]为此字符串s[1...i]的最小循环节(i为字符串的结尾)的长度

所以直接:len-nxt[len]-len%(len-nxt[len]

还有一种特殊情况需要判断就是最后next[i]==0时,直接增加全部字符,举几个例子就可以推出。

大佬博客:https://blog.csdn.net/u013480600/article/details/22954037

代码实现:

#include<cstdio>
#include<iostream>
#include<fstream>
#include<algorithm>
#include<functional>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<numeric>
#include<cctype>
#include<cmath>
#include<ctime>
#include<queue>
#include<stack>
#include<list>
#include<set>
#include<map>
using namespace std;
 
const int N = 1000002;
int nxt[N];
char  T[N];
int  tlen;
 
void getNext()
{
    int j, k;
    j = 0; k = -1;
	nxt[0] = -1;
    while(j < tlen)
        if(k == -1 || T[j] == T[k])
           {
           	nxt[++j] = ++k;
           	if (T[j] != T[k]) //се╩╞
				nxt[j] = k; 
           } 
        else
            k = nxt[k];
 
}


int main()
{
 
    int t;
	cin>>t;
    while(t--)
    {
    	scanf("%s",&T);
    	tlen= strlen(T);
    	
		getNext();
		if(nxt[tlen]==0)
		{
		printf("%d\n",tlen) ;
		continue;
		}
      
	   	if(tlen%(tlen-nxt[tlen])==0)
       	printf("0\n");
		else
		{
			
			printf("%d\n",tlen-nxt[tlen]-tlen%(tlen-nxt[tlen]));
		} 	
       	 
    }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/sdz20172133/article/details/84487252
今日推荐