南阳oj 94题------cigarettes

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_41657943/article/details/79490356
              时间限制: 3000 ms  |  内存限制: 65535 KB
描述

Tom has many cigarettes. We hypothesized that he has n cigarettes and smokes them

one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette.
Now,do you know how many cigarettes can Tom has?

输入
First input is a single line,it's n and stands for there are n testdata.then there are n lines ,each line contains two integer numbers giving the values of n and k.
输出
For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.
样例输入
3
4 3
10 3
100 5
样例输出
5
14
124

题目链接:http://acm.nyist.edu.cn/JudgeOnline/problem.php?pid=94

代码:

#include <stdio.h>
int main()
{
    int n,i,j,k,u,p,o,m;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d%d",&j,&k);
        p=j;
        u=0;
        for(;j>=k;)
        {
            m=j/k;
            o=j%k;
            u=u+m;
            j=o+m;
        }
        printf("%d\n",u+p);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41657943/article/details/79490356