HDU1150 Machine Schedule【二分图 最小点覆盖】

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10961    Accepted Submission(s): 5424


 

Problem Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

Output

The output should be one integer per line, which means the minimal times of restarting machine.

 

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3

Source

Asia 2002, Beijing (Mainland China)

问题链接:HDU1150 Machine Schedule

问题描述:给你两台机器A和B,A机器有n种模式,B机器有m种模式,初始时都是0,现在给你k个任务,每个任务可以由机器A的x模式完成或者机器B的y模式完成,而每次改变机器的模式都要重启一次,问你最少的重启次数使得完成所有任务!

解题思路: 由于初始模式为0,所以可由模式0完成的任务可以不考虑;将机器A和机器B的模式互相连接,某个任务由A的x和B的y完成那么x与y相连,在这个二分图中找出最少的点使得所有的边都至少有一个端点被选中,而这就是求最小点覆盖,而最小点覆盖=最大匹配。

AC的C++程序

#include<iostream>
#include<vector>
#include<cstring>

using namespace std;

const int N=210;

vector<int>g[N];
bool vis[N];
int link[N];

int find(int x)
{
	for(int i=0;i<g[x].size();i++)
	{
		int y=g[x][i];
		if(!vis[y])
		{
			vis[y]=true;
			if(link[y]==-1||find(link[y]))
			{
				link[y]=x;
				return true;
			}
		}
	}
	return false;
}

int main()
{
	int m,n,k,a,b;
	while(~scanf("%d",&n)&&n)
	{
		scanf("%d%d",&m,&k);
		for(int i=1;i<=n+m;i++)
		  g[i].clear();
		while(k--)
		{
			int id;
			scanf("%d%d%d",&id,&a,&b);
			if(a==0||b==0) continue;
			b+=n;
			g[a].push_back(b);
			g[b].push_back(a);
		}
		int ans=0;
		memset(link,-1,sizeof(link));
		for(int i=1;i<=n;i++)
		{
			memset(vis,false,sizeof(vis));
			if(find(i))
			  ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/84677438