程序设计基础66 STL之vector中大规模数据排序最好不用string

1047 Student List for Course (25 分)

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

一,关注点。

1,本题我开始是建立了一个string类型的二维vector的,vector下标存储课程号,但是运行超时,因为大规模string类型数据排序需要耗费大量的时间。

2,所以这里采用数字代替string类型进行排序,注意排序的写法。

bool cmp(int a, int b) {
	return strcmp(student[a], student[b]) < 0;
}

//主函数里面是这样写

for (int i = 1; i <= K; i++) {
	sort(vec[i].begin(), vec[i].end(), cmp);
	printf("%d %d\n", i, vec[i].size());
	for (int j = 0; j < vec[i].size(); j++) {
		printf("%s\n", student[vec[i][j]]);
	}
}

二,正确代码

#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
const int max_n = 50000;
char student[max_n][5];
vector<int> vec[3000];
bool cmp(int a, int b) {
	return strcmp(student[a], student[b]) < 0;
}
int main() {
	int N = 0, K = 0;
//	char name[5];
	int num = 0, id = 0;
	scanf("%d %d", &N, &K);
	for (int i = 0; i < N; i++) {
		scanf("%s", student[i]);
		scanf("%d", &num);
		for (int j = 0; j < num; j++) {
			scanf("%d", &id);
			vec[id].push_back(i);
		}
	}
	for (int i = 1; i <= K; i++) {
		sort(vec[i].begin(), vec[i].end(), cmp);
		printf("%d %d\n", i, vec[i].size());
		for (int j = 0; j < vec[i].size(); j++) {
			printf("%s\n", student[vec[i][j]]);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq2285580599/article/details/84634361