PTA 词频统计(30)

版权声明:如果路过的各位大佬想对菜鸡进行指点请加QQ:3360769137 https://blog.csdn.net/PleasantlY1/article/details/83180678

请编写程序,对一段英文文本,统计其中所有不同单词的个数,以及词频最大的前10%的单词。

所谓“单词”,是指由不超过80个单词字符组成的连续字符串,但长度超过15的单词将只截取保留前15个单词字符。而合法的“单词字符”为大小写字母、数字和下划线,其它字符均认为是单词分隔符。

输入格式:

输入给出一段非空文本,最后以符号#结尾。输入保证存在至少10个不同的单词。

输出格式:

在第一行中输出文本中所有不同单词的个数。注意“单词”不区分英文大小写,例如“PAT”和“pat”被认为是同一个单词。

随后按照词频递减的顺序,按照词频:单词的格式输出词频最大的前10%的单词。若有并列,则按递增字典序输出。

输入样例:

This is a test.

The word "this" is the word with the highest frequency.

Longlonglonglongword should be cut off, so is considered as the same as longlonglonglonee.  But this_8 is different than this, and this, and this...#
this line should be ignored.

输出样例:(注意:虽然单词the也出现了4次,但因为我们只要输出前10%(即23个单词中的前2个)单词,而按照字母序,the排第3位,所以不输出。)

23
5:this
4:is

思路:结构体排序直接模拟。map也行。注意状态的初始化。

代码如下:


#include<set>
#include<map>
#include<list>
#include<deque>
#include<cmath>
#include<queue>
#include<stack>
#include<string>
#include<vector>
#include<stdio.h>
#include<sstream>
#include<stdlib.h>
#include<string.h>
//#include<ext/rope>
#include<iostream>
#include<algorithm>
#define pi acos(-1.0)
#define INF 0x3f3f3f3f
#define per(i,a,b) for(int i=a;i<=b;++i)
#define LL long long 
#define swap(a,b) {int t=a;a=b;b=t} 
using namespace std;
//using namespace __gnu_cxx;
struct node{
	string s1;
	int num;
}p[10000];
int cmp(node a,node b)
{
	if(a.num==b.num) return a.s1<b.s1;
	return a.num>b.num;
}
int main()
{
	char ch;
	int k=0;
	string s,s1;
	while(cin>>s)
	{
		s1="";
		int l,fag=0,fag1=0,z=0;
		per(i,0,s.size()-1)
		{
			fag=0;
			if(s[i]>='0'&&s[i]<='9') s1+=s[i],z++;
			else if(s[i]>='a'&&s[i]<='z') s1+=s[i],z++;
		    else if(s[i]>='A'&&s[i]<='Z') s1+=s[i]-'A'+'a',z++;
		    else if(s[i]=='_') s1+=s[i],z++;
		    else if(s[i]=='#') {fag1=1;break;} 
			else 
			{
				per(i,0,k)
                {
        	        if(p[i].s1==s1)  p[i].num++,fag=1;
		        }
		        if(fag==0)
		        {
			        p[k].s1=s1;
			        p[k].num=1;
			        k++;
		        }
		        s1="";
		        z=0;
			}   
			if(z==15) break;
		}
		//cout<<s1;
        per(i,0,k)
        {
        	if(p[i].s1==s1) p[i].num++,fag=1;
		}
		if(fag==0)
		{
			p[k].s1=s1;
			p[k].num=1;
			k++;
		}
		if(fag1==1) break;
	}
	sort(p,p+k,cmp);
    cout<<k<<endl;
    per(i,0,k/10-1)
    {
    	cout<<p[i].num<<":"<<p[i].s1<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/PleasantlY1/article/details/83180678
PTA