PAT 1037 Magic Coupon (25)

1037 Magic Coupon (25)(25 分)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​ product values. Here 1≤N​C​​,N​P​​≤10​5​​, and it is guaranteed that all the numbers will not exceed 2​^30​​.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

思路:

实际上就是两个数组,两两相乘找到最大的乘积之和。先将数组排序,大的正数和大的正数乘,小的负数和小的负数乘,多余的部分可以舍弃。

代码:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cctype>
#include <climits>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <stack>
#include <map>  
#include <set>
using namespace std;

int main()
{
	int n1, n2;
	cin >> n1;
	vector<int> a(n1);
	for (int i = 0; i < n1; i++)
		cin >> a[i];
	cin >> n2;
	vector<int> b(n2);
	for (int i = 0; i < n1; i++)
		cin >> b[i];
	sort(a.begin(), a.end());
	sort(b.begin(), b.end());
	int i = 0, j = 0, sum = 0;
	while (i < n1 && j < n2 && a[i] < 0 && b[j] < 0)
		sum += a[i++] * b[j++];
	i = n1 - 1, j = n2 - 1;
	while (i >=0 && j >=0 && a[i] > 0 && b[j] > 0)
		sum += a[i--] * b[j--];
	cout << sum << endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ryo_218/article/details/82387540
今日推荐