PAT甲级1005 Spell It Right

题目描述:
Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10
​100
​​ ).

Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345
Sample Output:
one five

题目大意:
给一串数字,求和,将该数的每个数字用英文打出。

代码如下:

#include <iostream>
using namespace std;
int main()
{
    string s,s2[]={"zero","one","two","three","four","five","six","seven","eight","nine"};
    cin>>s;
    int sum=0,k;
    for(int i=0;i<s.size();i++)
        sum+=s[i]-'0';
    string s3=to_string(sum);
    for(int i=0;i<s3.size();i++){
        cout<<s2[s3[i]-'0'];
        if(i!=s3.size()-1) cout<<" ";
    }
    return 0;
}

来总结一下:
1)数字的最大范围为10^100,所以只能用string 类来存储,求和完之后,将int转化为string类,然后对应输出相应的英文字母。

猜你喜欢

转载自blog.csdn.net/sun9979/article/details/84795685
今日推荐